0

When I ran: sudo apt-get install vlc- I got:

ravan@ravan:~$ sudo apt-get install vlc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  vlc : Depends: vlc-nox (= 2.1.6-0ubuntu14.04.1) but 2.2.1~trusty1 is to be installed
     Depends: libvlccore7 (>= 2.1.0) but it is not going to be installed
     Recommends: vlc-plugin-notify (= 2.1.6-0ubuntu14.04.1) but 2.2.1~trusty1 is to be installed
     Recommends: vlc-plugin-pulse (= 2.1.6-0ubuntu14.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

ravan@ravan:~$ apt-cache policy vlc-nox
vlc-nox:
    Installed: 2.2.1~trusty1
    Candidate: 2.2.1~trusty1
   Version table:
   *** 2.2.1~trusty1 0
           100 /var/lib/dpkg/status
       2.1.6-0ubuntu14.04.1 0
            500 http://security.ubuntu.com/ubuntu/ trusty-security/universe amd64 Packages
           500 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe amd64 Packages
       2.1.2-2build2 0
          500 http://archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages

ravan@ravan:~$ apt-cache policy libvlccore7
libvlccore7:
    Installed: (none)
    Candidate: 2.1.6-0ubuntu14.04.1
   Version table:
      2.1.6-0ubuntu14.04.1 0
        500 http://security.ubuntu.com/ubuntu/ trusty-security/universe amd64 Packages
        500 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe amd64 Packages
        100 /var/lib/dpkg/status
      2.1.2-2build2 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages

ravan@ravan:~$ sudo apt-get install libvlccore7
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
   libvlccore7 : Depends: vlc-data (= 2.1.6-0ubuntu14.04.1) but 2.2.1~trusty1 is to be installed
 E: Unable to correct problems, you have held broken packages.

ravan@ravan:~$ apt-cache policy vlc-data
vlc-data:
  Installed: 2.2.1~trusty1
  Candidate: 2.2.1~trusty1
   Version table:
  *** 2.2.1~trusty1 0
        100 /var/lib/dpkg/status
      2.1.6-0ubuntu14.04.1 0
        500 http://security.ubuntu.com/ubuntu/ trusty-security/universe amd64 Packages
        500 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe amd64 Packages
      2.1.2-2build2 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
  • may I know reason fr downvote? – Ravan Dec 19 '15 at 1:53
1

It seems to me that you have:

  1. installed VLC from a PPA
  2. removed VLC. That will live some of its dependencies installed.
  3. removed that PPA
  4. tried to install VLC again not from that PPA without cleaning residues.

To fix that:

  • It is recommended to run sudo apt-get autoremove after removing a package to remove auto installed dependencies related to it.

  • You can also use ppa-purge to downgrade all packages from that ppa

    Note: if you have removed the PPA, add it again, Otherwise ppa-purge will not work.

    sudo apt-get install ppa-purge
    sudo ppa-purge <ppa:...>
    
  • Another way, Use synaptic set filter by origin then remove the package from that PPA all at one or downgrade grade them one by one.

    If you forgot the name of a removed PPA, you find them in Origin:local same as locally installed debian packages.

  • +1 for generalized solution :) what if I forgot PPA name, use synaptic? – Ravan Dec 18 '15 at 14:34
  • 1
    @Ravan, yes use synaptic , i have updated my answer – user.dz Dec 18 '15 at 15:18
0

From the output of apt-cache policy vlc-nox vlc-data. You (I) have versions more than required. These two are reason for conflicts.First remove those two:

sudo apt-get purge vlc-nox vlc-data

Now run:

sudo apt-get install vlc

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.