1

I had a bunch of held packages and attempted to fix it using Aptitude as suggested here. It mentioned removing a bunch of packages, but I accepted that after seeing a few of the packages being updated in the background.

After that was all done I thought I had fixed all of my "issues", but when I clicked the applications menu (Slingshot) a file browser popped up. Slingshot was no longer installed and when I tried to reinstall it via apt I got the following

Depends: libplank0 (>= 0.10.1) but it is not going to be installed.

I get similar errors when I try to install plank (an attempt to fix this problem).

I restarted my machine but now after login all I get is my background image. All my other attempts to reinstall the missing packages have been via ssh.

Is there any way to roll back? Or run a repair, that won't compromise my data

Please help me!

The output from apt-cache policy libplank0 plank slingshot is:

libplank0:
Installed: (none)
Candidate: 0.10.1-0elementary1~ubuntu14.04.2
Version table:
 0.10.1-0elementary1~ubuntu14.04.2 0
    500 http://ppa.launchpad.net/elementary-os/stable/ubuntu/ trusty/main amd64 Packages
 0.10.0+bzr1396-0ubuntu1~14.04~ricotz1 0
    100 /var/lib/dpkg/status
plank:
Installed: 0.10.9+bzr1464-0ubuntu1~14.04~ricotz1
Candidate: 0.10.9+bzr1464-0ubuntu1~14.04~ricotz1
Version table:
*** 0.10.9+bzr1464-0ubuntu1~14.04~ricotz1 0
    500 http://ppa.launchpad.net/ricotz/docky/ubuntu/ trusty/main amd64 Packages
    100 /var/lib/dpkg/status
 0.10.1-0elementary1~ubuntu14.04.2 0
    500 http://ppa.launchpad.net/elementary-os/stable/ubuntu/ trusty/main amd64 Packages

slingshot:
 Installed: (none)
 Candidate: 0.9-1
 Version table:
   0.9-1 0
      500 http://za.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages`
  • press ctrl+Alt+F1 and run sudo apt-get install --reinstall elementary-desktop – Ravan Dec 16 '15 at 11:38
  • Hi Ravan, thanks for the help but I'm afraid it didn't help. I run the command then switched to my desktop and it was the same. Even after a reboot it is still blank – SpydaMonky Dec 17 '15 at 12:11
  • "same"? are you still in login screen? If not, can you open terminal ? Use shortcut win+T – Ravan Dec 17 '15 at 12:13
  • Please edit and add output of apt-cache policy libplank0 plank slingshot – Ravan Dec 17 '15 at 12:16
  • Hey Ravan, I have added the output for you. What I mean by "the same" is just the background image and cursor. I can't open terminal or anything else via shortcuts. All I can do is move the cursor – SpydaMonky Dec 21 '15 at 15:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.