3

(First of all, I'm totally new to this)

I've installed elementary OS alongside Windows 10 (shrinking the main partition of windows with a new empty partition of 100GB, and then installed Elementary using an USB flash drive).

elementary OS seems to work perfectly, but i can't access Windows Boot Manager anymore from the GRUB Menu, it says: enter image description here

Keep it mind that i'm using a Lenovo laptop (FLex 14-D).

Can you help me please?

  • Same problem.Fixed by installng rEFInd – Suici Doga Apr 11 '16 at 2:32
1

ok I've done boot-repair from a live-usb and now in the grub menu i've these options to choose.

What do i have to do in order to access to Windows?

Also i think i've forgotten to disable Secure Boot at the beginning, is it still necessary after boot-repair.

[SOLVED] better than i thought, it was the first one "Windows UEFI recovery bootmgfw.efi" (don't know why but it works)

Thanks everyone for all the support.

0

try firing up a console and sudo grub-update, then restart and boot windows again.

  • i've tried to update grub but it says the same thing. – GageBlackW23 Dec 15 '15 at 11:45
  • then it probably is something windows-related. can you show us blkid ? – Michael Shalom Dec 15 '15 at 14:04
  • done (the picture in the OP) – GageBlackW23 Dec 15 '15 at 14:39
  • i am sorry but you've probably overwritten the windows MBR petition(the system reserved one that costs you 100mb), i'm not really the best when in comes to MS stuff but i'd say you mount your windows main petition, backup your things, and reinstall windows. – Michael Shalom Dec 16 '15 at 14:17
  • kraken@MichaelShalom:~$ sudo blkid [sudo] password for kraken: /dev/sda1: LABEL="System Reserved" UUID="80D42D64D42D5DA2" TYPE="ntfs" <-you've overwritten this ------------------------- /dev/sda2: UUID="7A58439F584358D1" TYPE="ntfs" ------------------------- /dev/sda4: LABEL="storeage" UUID="82AE2422AE2410E9" TYPE="ntfs" ------------------------- /dev/sda5: UUID="40eafe67-64b6-4916-a310-0688a6c17675" TYPE="ext4" ------------------------- /dev/sda6: UUID="e9c1e289-075d-449d-90db-a84a11baaeed" TYPE="swap" – Michael Shalom Dec 16 '15 at 14:18
0

I suggest you to follow the Boot-repair instructions, available here: https://help.ubuntu.com/community/Boot-Repair

If your Windows 10 partition is still intact you will be fine following the instructions.

  • Generally it is good practice to include necessary content here, and link at the end. – Lewis Goddard Dec 15 '15 at 18:34
  • I've tried to run Boot-repair from PPA, but it says to run boot repair from a Live CD or Live USB. (i will try it now). – GageBlackW23 Dec 17 '15 at 14:10
  • I've also noticed on system setup that i'm in UEFI Mode (do i have to change?), and there is a mode called "OS Optimized Defaults" and it is in "Win8 64bit mode". What is it? – GageBlackW23 Dec 17 '15 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.