I'm having a hard time starting with elementary OS.

After managing to install it from a USBKey (0.3.2 32bit version) on an old ACER AspireOne, erasing pre-existing system, I find myself unable to boot it. (I needed 3 attempts as I got twice a weird error of the installer being unable to write file, saying my hardrive must have a problem. In the end selecting the simplest options worked - no encryption, no update during install, no 3rd parties)

I first had to figure how to get a GRUB config (How can I fix a secure boot failing to grub when I installed 0.3.1?) but to no avail as I had no /boot/grub/grub.cfg file.

Booting from USB key and installing boot-repair helped me get a grub config (A fresh install boots to the grub command prompt). I now get a grub menu to choose from, but it unfortunately boots to a black screen. In desperation I've tried to add nomodeset to the command in grub (Black Screen after GRUB (Windows 8.1 dualboot)) but it didn't help.

Note that I have a weird message error: attempt to read or write outside of 'hd0' appearing before the grub menu and after the selection, just before the screen turn black.

I might be a bit unfortunate, but I was hopeful that choosing the simplest setup (full new install, single OS, no secure boot problem) would be straightforward.

  • 1
    hum, too bad nobody has a clue, I guess I'll need to wait for 0.4 to test it again...
    – coolnodje
    Commented Dec 18, 2015 at 8:46

1 Answer 1


I have same issue because elementary os have little bug in installing grub without internet.

When i connect to internet and installing again grub install properly.

May you have same issue, try to install it with internet connection

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.