1

I used rvm to install ruby 2.2.3. Then I installed rails 4.2.5. I create an app by rails new ... and then cd into it. I try to run it with rails server. And...

~/.rvm/gems/ruby-2.2.3/gems/bundler-1.11.0/lib/bundler/runtime.rb:80:in `rescue in block (2 levels) in require': There was an error while trying to load the gem 'uglifier'. (Bundler::GemRequireError)

That's what I get. In my Gemfile I have `gem 'uglifier', '>= 1.3.0'.

What am I missing? It's my first try in RoR and it's getting a bit frustrating.

0

Actually having meteor installed doesn't count as having nodejs installed. nodejs is required for uglifier package, so simple: apt install nodejs resolves the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.