2

I installed Firefox by doing this:

 1. wget
    https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/42.0/linux-x86_64/en-US/firefox-42.0.tar.bz2
 2. tar -xjvf firefox-42.0.tar.bz2
 3. sudo rm -rf /opt/firefox*
 4. sudo mv firefox /opt/firefox
 5. sudo ln -sf /opt/firefox/firefox /usr/bin/firefox

When I run it on terminal, the only option that I have when right click on Firefox's icon on Dock is "Close". How can I add Firefox to Dock?

  • 3
    Why aren't you installing firefox from official repositories by typing sudo apt-get install firefox into terminal or by installing from software center? – Rafael Dec 13 '15 at 19:24
  • @Rafael, it was a bad idea indeed. How do I fix this? – mykahveli Dec 15 '15 at 15:57
4

To get an icon on plank (and in slingshot) an app needs to have a corresponding .desktop file in /usr/share/applications/. The desktop file also handles MimeTypes and lets you specify additional menu options (such as 'Open New Window' etc.)

Note: If you install firefox from the apt repositories with sudo apt-get install firefox it will update to v42 and the desktop file will be created for you. Since you have already installed it by other means, here is the firefox.desktop file it includes.

  • 1
    Thanks, this solution worked for me. I added the firefox.desktop file to ~/.local/share/applications – Aaron Cunnington Sep 16 at 9:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.