6

I have a large folder of pdfs. Every time I open it with files it has to load these little preview icons which takes pretty much time. How can I disable this?

4

Pantheon-files uses a thumbnailer daemon called tumbler . You can disable generation of thumbnails for PDFs by opening a terminal and editing the config file.

sudo nano /etc/xdg/tumbler/tumbler.rc

Search for the section listed below-

# PDF/PS thumbnailer
[PopplerThumbnailer]
Disabled=false
Priority=1
Locations=
MaxFileSize=0

Change Disabled=false to Disabled=true (Ctrl+O,Enter to save the file, Ctrl+X to exit nano)

Then reset your thumbnail cache with rm -r ~/.cache/thumbnails

Note: Rather than disabling thumbnails for all PDFs, you could set the Locations or MaxFileSize options to your liking. Unfortunately though, as far as I can tell the Locations setting only allows you to whitelist rather than blacklist folders.

  • Thanks, it worked! Now it opens the folder much quicker! – spartakuskus Dec 13 '15 at 19:39
  • rm -r ~/.thumbnails it does not work in loki – vrcmr Jul 11 '17 at 9:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.