After changing my desktop background using a custom image, my desktop stays black, while the login screen has been reverted to the default image. How can I fix that (without copying the image to /usr/share/backgrounds)?

  • Will you please try my answer and let me know :)
    – Ravan
    Dec 10, 2015 at 2:02
  • @Ravan: Somehow it works now without changing, but in the background selection screen I can find a black image...
    – arc_lupus
    Dec 10, 2015 at 8:08
  • Ah? I still get black background for custom section (which you have asked) :)
    – Ravan
    Dec 10, 2015 at 8:23
  • can you please tell me "somehow"? I can't do that without following the below answers.
    – Ravan
    Dec 10, 2015 at 8:25
  • Will you please drop here
    – Ravan
    Dec 10, 2015 at 8:34

4 Answers 4


The bug: https://bugs.launchpad.net/switchboard-plug-pantheon-shell/+bug/1524723 did not appear in 0.3.2.

The solution would be update to 0.3.2

  • I'm experiencing this issue in 0.3.2. Jan 19, 2016 at 14:34
  • Will you please open a new post, for me and OP it was solved in 0.3.2 :)
    – Ravan
    Jan 21, 2016 at 14:05

Use dconf

Install dconf with the command:

sudo apt-get install dconf-editor

Open dconf org --> gnome --> desktop --> background.

Change picture uri. (total path of image)


If not working:

Open terminal and run:

gsettings reset-recursively org.gnome.desktop.background

Now try again to change the background.

The command form to change background is:

gsettings set org.gnome.desktop.background picture-uri file:///home/thepathtoyourfile/yourNewBackgroundFile.jpg

You can use gnome-tweak-tool to change background:

Install from software center,then open it. You can change background under Desktop tab



You can use wallch. Install it from software center.

Wallch is a General purpose Wallpaper Changer.

You can shuffle background after a predefined time interval. Browse to the location, import. Now right click on it for options.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.