1

I have download teamviewer.deb and click on it . It opened in Ubuntu Software center. And it shows the error

cant install libc6:i386 

so i found this below command and i tried it on terminal.

sudo apt-get install libc6-amd64 libc6

but it shows some error.

Reading package lists... Done
Building dependency tree       
Reading state information... Done
libc6 is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libc6-amd64:i386 : Depends: libc6:i386 (= 2.19-0ubuntu6) but it is not            going to be installed
 E: Unable to correct problems, you have held broken packages.

this is the output of `apt-cache policy libc6:i386'

 libc6:i386:
  Installed: (none)
  Candidate: 2.19-0ubuntu6
  Version table:
 2.19-0ubuntu6 0
    500 http://in.archive.ubuntu.com/ubuntu/ trusty/main i386 Packages

Here is the screenshot of exact one.

enter image description here

  • what is output of apt-cache policy libc6:i386 – Ravan Dec 7 '15 at 10:00
  • this is the output No command 'apt-cahe' found, did you mean: Command 'apt-cache' from package 'apt' (main) apt-cahe: command not found – Kvvaradha Dec 7 '15 at 10:22
  • your command typo man :) – Ravan Dec 7 '15 at 10:24
  • @Kvvaradha you mistyped it - it's C A C H E – user3 Dec 7 '15 at 10:24
  • sorry , now i typed it again, but it shows like this N: Unable to locate package libc – Kvvaradha Dec 7 '15 at 10:29
2

Open terminal and run:

sudo apt-get update #updates packages
sudo apt-get install -f #installs any missing packages if any
sudo apt-get install gcc-4.9-base:i386 libc6:i386 libgcc1:i386
  • still the same error . mine is 64 bit. while downloading debian. i see both 32 and 64 will work. – Kvvaradha Dec 7 '15 at 10:21
  • @Kvvaradha Please run: sudo apt-get install libc6:i386 and try instaling again :) – Ravan Dec 7 '15 at 10:34
  • still i am seeing the same errors. do i need to restart and try again ? – Kvvaradha Dec 7 '15 at 10:35
  • Can you add exact output of sudo apt-get install libc6:i386 – Ravan Dec 7 '15 at 10:39
  • I can see it . but mine doesnot look like this. see it, i have edited the question – Kvvaradha Dec 7 '15 at 10:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.