3

I am using elementary os freya. I followed this post to install skype.

ravan@ravan:~$ sudo apt-get install skype
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
skype : Depends: skype-bin
E: Unable to correct problems, you have held broken packages.

ravan@ravan:~$ sudo apt-get install sni-qt:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
sni-qt:i386 : Depends: libc6:i386 (>= 2.2) but it is not going to be installed
           Depends: libdbusmenu-qt2:i386 (>= 0.3.2) but it is not going to be installed
           Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
           Depends: libqt4-dbus:i386 (>= 4:4.6.1) but it is not going to be installed
           Depends: libqtcore4:i386 (>= 4:4.7.3-1ubuntu3~) but it is not going to be installed
           Depends: libqtgui4:i386 (>= 4:4.7.3) but it is not going to be installed
           Depends: libstdc++6:i386 (>= 4.1.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

No error message in:

sudo apt-get update    
sudo apt-get upgrade    
sydo apt-get dist-upgrade    
sudo apt-get install -f

I also tried to install from synaptic, it almost removing all indicators etc. Also it shows the package is broken.

ravan@ravan:~$ sudo apt-get install libc6:i386 libdbusmenu-qt2:i386 libgcc1:i386 libqt4-dbus:i386 libqtcore4:i386 libqtgui4:i386 libstdc++6:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
   libqt4-dbus:i386 : Depends: libqtdbus4:i386 (= 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1+elementary3~ubuntu0.3.1) but it is not going to be installed
                Depends: qdbus:i386 (= 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1+elementary3~ubuntu0.3.1)
 libqtcore4:i386 : Depends: libglib2.0-0:i386 (>= 2.22.0) but it is not going to be installed
 libqtgui4:i386 : Depends: fontconfig:i386
              Depends: libaudio2:i386 but it is not going to be installed
              Depends: libfontconfig1:i386 (>= 2.9.0) but it is not going to be installed
              Depends: libfreetype6:i386 (>= 2.3.5) but it is not going to be installed
              Depends: libglib2.0-0:i386 (>= 2.12.0) but it is not going to be installed
              Depends: libice6:i386 (>= 1:1.0.0) but it is not going to be installed
              Depends: libpng12-0:i386 (>= 1.2.13-4) but it is not going to be installed
              Depends: libqt4-declarative:i386 (= 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1+elementary3~ubuntu0.3.1) but it is not going to be installed
              Depends: libsm6:i386 but it is not going to be installed
              Depends: libxext6:i386 but it is not going to be installed
              Depends: libxi6:i386 (>= 2:1.2.99.4) but it is not going to be installed
              Depends: libxrender1:i386 but it is not going to be installed
              Recommends: libcups2:i386 but it is not going to be installed
              Recommends: qt-at-spi:i386 but it is not going to be installed
 libstdc++6:i386 : Depends: gcc-4.8-base:i386 (= 4.8.2-19ubuntu1) but it is not going to be installed
 E: Unable to correct problems, you have held broken packages.

EDIT 1:

I even tried from direct download, it shows Internal error, could not open.

EDIT 2 :

ravan@ravan:~$ sudo apt-get -o Debug::pkgProblemResolver=yes dist-upgrade
[sudo] password for ravan: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
Done
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

EDIT 3:

ravan@ravan:~$ sudo apt-get install --no-install-recommends skype
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
   skype : Depends: skype-bin
E: Unable to correct problems, you have held broken packages.
4
  • The quickest way to find such problem is to verify the enabled repositories in /etc/apt/sources.list file directly and don't trust software-properties-gtk GUI tool. trusty-security & trusty-updates should have same component (main universe multiverse restricted) same as in trusty.

  • You have the update channel disabled, if you look for example:

    libcgmanager0:
      Installed: 0.24-0ubuntu7.5
      Candidate: 0.24-0ubuntu7.5
      Version table:
     *** 0.24-0ubuntu7.5 0
            100 /var/lib/dpkg/status
         0.24-0ubuntu5 0
            500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Package
    

    From output of:

    apt-cache policy $(apt-rdepends skype 2>/dev/null | grep "^[a-zA-Z]" | sort | paste -s -d" ")
    

    You see that you have already 0.24-0ubuntu7.5 from the trusty-updates/main repository but the available ones is just 0.24-0ubuntu5 from trusty/main.

So, to fix it:

  1. Open Software & Updates.
  2. Go to Updates tab.
  3. Check trusty-updates to enable it.
  4. Close & Reload.

    Imgur

Note: If already enabled, please disable--> close without reload --> again enable --> close and reload.

Then try installing Skype again.

  • 1
    Well, it worked. Is there any alternative? because the answer looks simple, but its ground work is little big. IMHO – Ravan Dec 7 '15 at 13:22
  • Hey man, I have edited and included screenshot o_O – Ravan Dec 7 '15 at 13:33
  • @Ravan , thanks for screenshot. Yes there is, check sources.list file directly and don't trust software-properties-gtk. – user.dz Dec 7 '15 at 14:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.