4

I have tried to install Elementary OS on my external hard drive (1TB, USB3.0).

My computer is using UEFI and is alredy dual booting Ubuntu MATE and Windows 10.

I created a Live USB with UNetbootin, and installed Elementary to my external hard drive from it. I choose something else, choose my partition to mount as / (/dev/sdc2) and choose to install grub on my hard drive (/dev/sdc), and created an efi partition, with esp and boot flags(/dev/sdc4) It installed sucessfully. When I reboot, I choose to boot to my hard drive from f12 boot menu, and I have got the "grub>" minimal bash-like command line. I followed the instruction on this post : Launchpad bug. I have been able to have the grub menu of elementary and to boot on it. Then the elementary logo appears and then I fall in a ash shell, exactly like in this post : Same problem, but no working answer is posted here.

I have tried before without EFT partition. Then I reboot and from bios boot menu f12, there was no option for my hard drive. Legacy is not working on my computer.

I also tried to run boot repair but it doesn't work either.

I though that mabe the problem is that my partition table is msdos and not gpt.

closed as off-topic by RolandiXor Aug 16 '17 at 19:58

  • This question does not appear to be about elementary OS, within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • I'm voting to close this question as off-topic because it is too old to migrate (and the problem might not persist on newer releases) – Axel Advento Jul 20 '17 at 13:23
  • I'm voting to close this question as off-topic because it's apparently abandoned. – RolandiXor Aug 16 '17 at 19:58