1

I decided to leave windows and use Linux, but I have a problem - when I installed elementary OS I couldn't boot, a black screen appeared and says "minimal BASH like line editing is supported..." and that is it.

I tried to use boot-repair in a live USB, but it didn't work, here is the info that boot-repair shows me.

I've tried both of these but nothing works, can anyone help me please??

  • In the link answer, which method you followed? – Ravan Dec 4 '15 at 16:10
  • HAVE you tried disabling safe boot and UEFI? – lf_araujo Dec 4 '15 at 20:21
2
  1. Boot from the Live CD
  2. Open gparted → Right Click on sda1 → Flags: Check boot, quit
  3. Open terminal
  4. Mount partitions

    mkdir ~/efi
    mkdir ~/root
    sudo mount /dev/sda1 ~/efi/
    sudo mount /dev/sda2 ~/root/
    
  5. Reinstall grub

    sudo grup-install --efi-directory=/home/elementary/efi/ --root-directory=/home/elementary/root/ /dev/sda
    
  6. Reboot

0

I had the same problem after installing Freya. I think I solved it by starting boot-repair from a live USB, then opening the advanced options.

I think I unchecked "Restore EFI Backups" and made sure "Reinstall Grub" and "Purge GRUB before reinstalling it were checked"

I was then able to boot. There were lots of GRUB menu items so I installed GRUB customizer and used it to edit the GRUB menu.

I hope this helps.

Jay

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.