1

I have installed shotwell 0.18. After that when I open shotwell, it shows the message:

"Your photo library is not compatible with this version of Shotwell. It appears it was created by Shotwell 0.1.1 (schema 21). This version is 0.18.0 (schema 20). Please use the latest version of Shotwell."

I also tried installing latest available version 0.20, still problem exists.

Finally, I removed ~/.cache/shotwell results the error message disappeared (I am not sure). But when I open shotwell, it freezes.

Also how to revert back to 0.1.1

2

Removing the shotwell cache amounts to lose your database. In order to change the schema of your database:

  1. Make a copy of the database,
  2. Do echo "update versiontable set schema_version=20;" | sqlite3 ~/.local/share/shotwell/data/photo.db

I used this to move back from pantheon-photos to shotwell, when I got this error message from Shotwell: "Your photo library is not compatible with this version of Shotwell. It appears it was created by Shotwell 0.1.1 (schema 21). This version is 0.23.5 (schema 20). Please use the latest version of Shotwell."

1
  • Vincent D's answer solves the error and should be marked as solution.
    – Marc
    Apr 30 '18 at 11:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.