3

Since a couple of days ago my volume icon has disappeared from Wingpanel. I know this issue has surfaced before, but the go-to solution (install indicator-sound) is of no use (indicator-sound correctly installed).

As an addition, this issue is not user-related, since it affects me even if I log into a guest session.

Any help to troubleshoot this?

As per requested edit:

apt-cache policy indicator-sound
indicator-sound:
  Installed: 12.10.2+14.04.20140401-0ubuntu1+elementary4~ubuntu0.3.1
  Candidate: 12.10.2+14.04.20140401-0ubuntu1+elementary4~ubuntu0.3.1
  Version table:
 *** 12.10.2+14.04.20140401-0ubuntu1+elementary4~ubuntu0.3.1 0
        999 http://ppa.launchpad.net/elementary-os/os-patches/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status
     12.10.2+14.04.20140401-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

Update Dec.10: Just to let you know that the issue is still there. Despite Ravan's workarounds, the solution appears to work intermittently, meaning that every other reboot or so the volume icon doesn't show up. It's worth noticing that the service is active, though, because I can modify the volume via keyboard shortcuts. My feeling is that there's something wrong in Wingpanel and the way indicators are displayed or not.

  • Have you tried reinstall indicator-sound ? – Ravan Nov 30 '15 at 15:41
  • Hello, @Giulio any update? Please have a look at the answer and let me know elementaryos.stackexchange.com/questions/2646/… – Ravan Dec 3 '15 at 6:56
  • Nope, still not working. I have all the necessary packages correctly installed. – Giulio Sant Dec 4 '15 at 9:07
  • As I was saying in my comment below, it must be an autostart issue. – Giulio Sant Dec 4 '15 at 9:54
  • sorry, what do you mean? – Ravan Dec 4 '15 at 10:04
3

The following are possible solutions:

  • Reinstall indicator-sound

    Open terminal and run:

    sudo apt-get install --reinstall indicator-sound
    
  • Install dconf

    sudo apt-get install dconf-editor
    

    Now open dconf:

    com --> canonical --> indicator--> sound --> visible

    Imgur


If still not working:

Also make sure the /etc/xdg/autostart/indicator-sound.desktop file should be exactly like this:

[Desktop Entry]
Type=Application
Name=Indicator Sound
Exec=/usr/lib/x86_64-linux-gnu/indicator-sound/indicator-sound-service
OnlyShowIn=Unity;XFCE;GNOME;Pantheon;
NoDisplay=true
StartupNotify=false
Terminal=false
AutostartCondition=GNOME3 unless-session gnome
X-Ubuntu-Gettext-Domain=indicator-sound

Note: log out and log in


The problem is temporarily solved (see chat) after modifying /usr/share/upstart/xdg/autostart/indicator-sound.desktop and adding Pantheon to OnlyShowIn, like:

OnlyShowIn=Unity;XFCE;Pantheon;

There will be three auto start options used by indicators

/etc/xdg/autostart/indicator-sound.desktop
/usr/share/upstart/xdg/autostart/indicator-sound.desktop
/usr/share/upstart/sessions/indicator-sound.conf

1st is from freedesktop std, should be started by session
2nd startup app lauched by upstart
3rd upstart (session mode) deprecated i think and replace by 2nd file so in this case 1st is not working
hard to say as I never traced similar thing

Reference Sneetsher post in AU

  • Everything looks fine on my part. Running the desktop file, though, made the icon appear on the panel. Looks like a matter of autostart after all. – Giulio Sant Nov 30 '15 at 16:14
  • I have just edited my post, please have a look :) – Ravan Nov 30 '15 at 16:15
  • If still anything not working, edit your post and add output of apt-cache policy indicator-sound – Ravan Nov 30 '15 at 16:15
  • 1
    Had the same problem. (Re-)Installing indicator-sound worked for me. – mazienho Nov 30 '15 at 17:18
  • Nothing works so far. Still no icon at boot. – Giulio Sant Dec 1 '15 at 15:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.