2

I've installed PyChess (http://www.pychess.org/download/) But when I started I get this message:

Gtk-Message: Failed to load module "pantheon-filechooser-module"
(pychess:17640): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
(pychess:17640): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
Attempt to unlock mutex that was not locked
Aborted (core dumped)

I've done

sudo apt-get install libcanberra-gtk*
sudo apt-get install libcanberra-gtk-module:i386

But still not working.. Any ideas?

Updated:

sudo apt-cache policy pychess
pychess:
  Installed: 0.12~beta3-1
  Candidate: 0.12~beta3-1
  Version table:
     *** 0.12~beta3-1 0
    500 http://py.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
    100 /var/lib/dpkg/status
  • add output of apt-cache policy pychess – Ravan Nov 26 '15 at 1:40
1

I have got same error, while trying to solve this post.

Installation from terminal command sudo apt-get install pychess

we will get beta3 version, which is very old. (Refer here).

Now download 0.12.deb and install from software center.

Note: No need to remove installed pychess, you will get upgrade option.

Imgur

Imgur

  • did you do this? sudo apt-get install libcanberra-gtk* sudo apt-get install libcanberra-gtk-module:i386 – td18 Nov 26 '15 at 11:32
  • No, those errors/warnings are nothing to do with pychess @td18 – Ravan Nov 26 '15 at 11:33
  • @td18 Please follow the answer and let me know :) – Ravan Nov 26 '15 at 11:34
  • I've installed from the software centre but I still having those errors. Also when I do pychess --version Gtk-Message: Failed to load module "pantheon-filechooser-module" (pychess:7904): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita", (pychess:7904): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita", pychess 0.12beta3 (Anderssen) – td18 Nov 26 '15 at 11:48
  • @td18 Please run sudo apt-get install libcanberra-gtk-module and add output of apt-cache policy pychess to question :) – Ravan Nov 26 '15 at 11:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.