6

I read about Alt+Space keyboard Shortcut to change the keyboard layout, but it is not working, despite being defined in System Settings. What am I doing wrong?

9
  • Have you changed any settings? try to reassign: settings --> keyboard --> universal access --> here select "Next keyboard layout ", press Alt+Space. Please let me know :)
    – Ravan
    Commented Nov 22, 2015 at 14:45
  • @Ravan It does not help. All is same, shortcut doesn't work. Freya is fully updated.
    – Fireburn
    Commented Nov 22, 2015 at 15:36
  • Are you sure those two keys are working?
    – Ravan
    Commented Nov 22, 2015 at 15:38
  • Absolutely sure, if you mean that keyboard recognized them. Keys are working, but nothing change... :(
    – Fireburn
    Commented Nov 22, 2015 at 15:39
  • 1
    Wow, it works! Shift+Space worked. But what's up with Alt+Space?
    – Fireburn
    Commented Nov 22, 2015 at 15:45

3 Answers 3

3

With Alt+Space may be problems, but you can change Win+Space in System Settings (Switchboard). This combination does not fail, and works without problems.

Also you can set some other combinations that are not available from Switchboard.

Shift+Alt:

gsettings set org.pantheon.desktop.gala.keybindings switch-input-source "['<Alt>Shift_L', '<Alt>Shift_R', '<Shift>Alt_L', '<Shift>Alt_R']"

Shift+Ctrl:

gsettings set org.pantheon.desktop.gala.keybindings switch-input-source "['<Ctrl>Shift_L', '<Ctrl>>Shift_R', '<Shift>Control_L', '<Shift>Control_R']"

Caps Lock:

gsettings set org.pantheon.desktop.gala.keybindings switch-input-source "['Caps_Lock']"
3
  • why Alt+Space have problem?, OP already changed to custom shortcut
    – Ravan
    Commented Nov 23, 2015 at 7:59
  • @Ravan alt+space sometimes doesn't work, for example after kernel upgrade.
    – png2378
    Commented Nov 23, 2015 at 8:03
  • sounds logical, can you confirm this
    – Ravan
    Commented Nov 23, 2015 at 8:05
0

While solving this issue, I messed up something in dconf and results Alt+Space stopped working. The shortcut working with other combinations.(Even I have set all settings to : Default Settings)

Finally reboot solved the issue.

3
  • Strange... I don't recall ever modifying something in dconf. I don't know if dconf-editor is installed at all!
    – Fireburn
    Commented Nov 22, 2015 at 19:08
  • Oh, and, by the way, Alt+Space works when I made it "Previous Keyboard Layout" shortcut.
    – Fireburn
    Commented Nov 22, 2015 at 19:12
  • @Fireburn I observed one point, but I can't confirm it : When Alt+Space stops working, "Reassaign working for me "
    – Ravan
    Commented Nov 23, 2015 at 3:45
-1

I found another work around by binding 'Previous Keyboard Layout' to Alt+Space. It works fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.