After upgrading a fresh installed elementary OS freya 0.3.1 64bit with apt-get dist-upgrade on start up (booting the computer) and shut-down instead of the "e" logo appears a fast running list of commands on display. The elementary desktop seems not to be affected.

Note: I already looked at this question. But it does not affect me, because in the info panel in system settings the "e" logo appears correctly on my computer.

I remember when I ran apt-get dist-upgrade during the upgrade process I was confronted with a simple graphical choice within the terminal that stated something like "there is a new grub version but your existing grub version was modified" giving me the option to "use version from packet manager" "use existing version" and "show the difference". I tried showing the difference but did not understand what the difference is. So I choose to use the new version from the packet manager since I wanted to upgrade my installation.

I assume maybe I should have stayed with the than existing (old) modified version of grub? Maybe the modification was just to include the "e" logo instead of running messages too fast to read?

If so my question is:
1. does this affect any more than the start-up display?
2. How can I revert to the modified grub without reinstall the whole elementary OS?

Maybe it is of interest that between fresh install and update/upgrade I did only one thing: I changed in /etc/apt/sources.list.d/ in the file elementary.list the broken update links pointing to deb http://ppa.launchpad.net/elementary-os/stable/ubuntu freya main to deb http://ppa.launchpad.net/elementary-os/stable/ubuntu trusty main and in patches.list from "http://ppa.launchpad.net/elementary-os/os-patches/ubuntu freya main" to "http://ppa.launchpad.net/elementary-os/os-patches/ubuntu trusty main" since no subdirectory freya exists on ppa.launchpad.net and Freya is build on Trusty. (see the answer to my question here and the selection options given here)

Note 2: My question was down-voted. I would like to know why in order to improve my question. And still would like to have answer to my two-fold question above. Especially the second part on how to revert to original start-up screen.

  • Could you provide the output of cat /etc/default/grub | grep LINUX_DEFAULT
    – elmato
    Nov 21 '15 at 1:16
  • Same problem here. You're not alone! :) although I'm not sure what could be the cause of the probleme in my case...
    – deesnook
    Nov 21 '15 at 23:33
  • @elmato Here comes the output of cat /etc/default/grub: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" ( sorry for delay, my internet provider had connection problems during the weekend.)
    – Olaf
    Nov 23 '15 at 11:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.