I have trouble with updating a new installed elementary OS 0.3.1 Freya (64-bit) system. The software updater starts and after a while fails: "Failed to download repository information. Check your Internet connection". My Internet connection works fine.

When I click on the "settings" option in that message I got the "updates" tab with security updates checked and the others unchecked. When trying to check other options I ran into problems like described here and followed the advice to uncheck all double entries in the software-updater.

I followed also the advice from here to remove the cache with a sudo rm /var/cache/apt/*.bin command

When I close the settings the system takes some time and then I got the message: "Not all updates can be installed Run a partial upgrade, to install as many updates as possible ..." when I click the option "Partial Upgrade" I get the message "Can not upgrade. An upgrade from 'freya' to 'trusty' is not supported with this tool."

When I open the Software Updater again and choose the "Continue" option this time I get a new message: "Updated software is available for this computer. Do you want to install it now? Under "Details of updates" there is a list of software with check-boxes. checked is: LibreOffice Base, LibreOffice Impress, VLC Media Player, 7z und 7za Archivierungsprogramm, HTML-Syntaxprüfer, LibreOffice component for bulding da..., Video-Dekodierungs und Präsentation..., e Ubuntu base. and an info: 15,6 MB will be downloaded.

When I click on "Install now" for a short time a message window "installing" pops up to be replaced short after with a message "Requires installation of untrusted packages. This requires installing packages from unauthenticated sources." With the option "settings" I get again in the window/panel with settings and the problem mentioned before. With a click on "ok" the Software Updater just quits.

I also tried the solution mentioned here and run in terminal with root apt-get update (in fact I tried this before several times) But it did not help for me.

I got errormessages like this:

From Software Updater:

W:Failed to fetch http://ppa.launchpad.net/elementary-os/stable/ubuntu/dists/freya/main/source/Sources 404  Not Found , W:Failed to fetch... , W:Failed to fetch http://de.archive.ubuntu.com/ubuntu/dists/trusty/Release  Unable to find expected entry 'contrib/source/Sources' in Release file (Wrong sources.list entry or malformed file) , E:Some index files failed to download. They have been ignored, or old ones used instead.

From apt-get update:

W: Fehlschlag beim Holen von http://ppa.launchpad.net/elementary-os/stable/ubuntu/dists/freya/main/source/Sources 404  Not Found   ...

W: Fehlschlag beim Holen von http://ppa.launchpad.net/elementary-os/os-patches/ubuntu/dists/freya/main/binary-i386/Packages 404  Not Found   E: Einige Indexdateien konnten nicht heruntergeladen werden. Sie wurden ignoriert oder alte an ihrer Stelle benutzt.

For a solution it maybe is of interest that I struggled a lot with dual-boot elementary os alongside a pre-installed Win7 on Acer TMP 645. Finally got it work with rEFInd Bootmanager renamed and replaced into the windows-bootmanager place (seems the firmware / microsoft bootmanager prevents linux from adding new bootloaders to the EFI and deletes them every time on restart).

I indeed installed extra software: rEFInd of course and some extra software through the software center yesterday. The error messages I get from apt-get point to http:// security.debian.org and to ppa.launchpad.net/elementary-os/stable/... Before the extra software installed yesterday I also tried to update/upgrate with apt-get and already got the error message for the ppa.launchpad.net/elementary-os/stabel/ branch. Since the name of the branch contains "elementary-os" I wounder if i could/should disable/uninstall these packages as suggest in an earlier answer to this questions on Software updater doesn't work anymore correctly . It seems to me pointing to the core part of the elementary distro?! And if I should so that - how could I do that?

note: I am well conneted to the internet, that is not the problem.

Thank you for any help and advice Olaf

I posted the content of apt-get update and of /etc/apt/sources.list to paste.ubuntu (see links in comments to this post)

  • Hey, Olaf, welcome to eos stackexchange! It seems there's somekind of malformed URLs for fetching data. Can you post the contents of /etc/apt/sources.list file? Nov 18 '15 at 21:14
  • Hi shookees, thank your for asking. Here ist the list: it seems I need to append my original question with the contents of /etc/apt/sources.list
    – Olaf
    Nov 18 '15 at 21:38
  • Not necessarily, you can upload it to paste.ubuntu.com or pastebin.com and just post the link here Nov 18 '15 at 21:44
  • Thanks for that tip. Here comes the link to paste.ubuntu : paste.ubuntu.com/13335135 with the content of /etc/apt/sources.list
    – Olaf
    Nov 18 '15 at 21:51
  • And this is the full output of apt-get update in the terminal: paste.ubuntu.com/13335190
    – Olaf
    Nov 18 '15 at 21:56

I am not shure, but maybe this could be part of the solution: I followed the links in ppa.launchpad.net/elementary-os/... that are broken and step by step deleted from the end of the URL the parts between two / symbols. Resulting the first URL that works is: http://ppa.launchpad.net/elementary-os/stable/ubuntu/dists/ and there are two relative new folders build on 4 oct 2015: "devel" and "trusty". Maybe the structure of the repository has been changed recently from absolut names (e.g. luna, freya,...) to names relative to the status of the distribution (devel, trusty) but it was forgotten to update the URL in the sourcelist file?!

Update: It seems I was on the right track. See answer to this question. It seems that it is a bug in the current (as of 20nov2015) freya 0.3.1 distribution. So this is what you have to do when you run into the same problem:

go to /etc/apt/sources.list.d

and change "freya" to "trusty" in the pathes. i.e.

change in elementary.list the path from deb http://ppa.launchpad.net/elementary-os/stable/ubuntu freya main
deb-src http://ppa.launchpad.net/elementary-os/stable/ubuntu freya main
deb http://ppa.launchpad.net/elementary-os/stable/ubuntu trusty main
deb-src http://ppa.launchpad.net/elementary-os/stable/ubuntu trusty main

change in patches.list from
deb http://ppa.launchpad.net/elementary-os/os-patches/ubuntu freya main
deb-src http://ppa.launchpad.net/elementary-os/os-patches/ubuntu freya main
deb http://ppa.launchpad.net/elementary-os/os-patches/ubuntu trusty main
deb-src http://ppa.launchpad.net/elementary-os/os-patches/ubuntu trusty main

then running sudo apt-get update shoud work fine

Note: you need root-priviliges to change the files. I edited them with scratch and stored the files in my home documents archive. Then used terminal mv and cp commands to replace the old files with the new ones. There might be a more convenient way to do this.

Not the answer you're looking for? Browse other questions tagged or ask your own question.