I find it puzzling that every time I've cropped an image with Photo Viewer, I'm unable to change the aspect ratio of the crop region (it remains the same as the aspect ratio of the original image). I'm not sure whether Photo Viewer on elementary is the same as the Shotwell Photo Viewer on Ubuntu, which has a small configuration popup when cropping, but the app looks very similar, so I'm thinking the configuration popup should be accessible somewhere? Or if the app isn't the same, is it meant to be this way?


2 Answers 2


The aspect ratio can be changed:

To enable it, try running this command:

gsettings reset-recursively org.yorba.shotwell.crop-settings

Image Source

  • 2
    Why this isn't enabled by default is beyond me, but thanks for the answer - it worked perfectly! Commented Dec 6, 2015 at 19:23
  • 1
    Hi I have tried gsettings reset-recursively org.yorba.shotwell.crop-settings and it says No such schema 'org.yorba.shotwell.crop-settings' Commented May 15, 2017 at 17:53
  • Hi @IvanVilanculo sorry for the delay in replying. I've not got eOS installed right now so give me an hour or two to check. Can you confirm which version of Elementary OS you installed, and when did you install?
    – user3
    Commented May 17, 2017 at 16:14

On elementary OS Loki 0.4, I solved the problem by installing dconf-editor

sudo apt-get install dconf-editor

Then with dconf-editor navigate to org/panthenon/photos/crop-settings and set last-crop-height, last-crop-menu-choice and last-crop-height values to 0. Please note it should be exactly zero otherwise it will not work!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.