0

Yesterday I installed the nvidia-driver-525 for my laptop with a GTX 1660ti and an AMD CPU with integrated graphics.

Everything worked fine (meaning I could see output on both screens), until I booted my laptop today. My external display works (supposedly the output of the nvidia gpu), but my internal laptop display displays a single underscore. I can switch to TTY1 and the TTY shows up on the internal display.

When I go to display settings, I can only see the external display. The internal display doesn't show up there.

If I unplug my external screen, nothing shows up on the internal screen and the only thing I see is the single underscore at the left of the screen.

I tried restarting lightdm, without any success.

I don't know what causes this and I hope someone can help. Thanks!

lspci | grep 'VGA' output:

01:00.0 VGA compatible controller: NVIDIA Corporation Device 1f95 (rev a1)
05:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Renoir (rev c7)

xrandr output:

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 527mm x 296mm
   1920x1080     60.00 +  74.97*   59.94    50.00  
   1680x1050     59.95  
   1600x900      60.00  
   1440x900      59.89  
   1280x1024     75.02    60.02  
   1280x800      59.81  
   1280x720      60.00    59.94    50.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    72.81    59.94  
1
  • how do you install the graphic driver?
    – hhh
    Commented Jan 5, 2023 at 10:22

1 Answer 1

0

I fixed the issue after finding this forum post: https://forums.linuxmint.com/viewtopic.php?t=360830

Apparently enabling Nvidia Performance mode in nvidia-settings disables the internal graphics, which explains why the internal laptop display stopped working.

After using sudo rm /etc/X11/xorg.conf the issue was resolved!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.