11

I'm not interested in cloud storage or anything like that, I just need to share out a folder so that OS X and Windows clients can connect to it. Connecting to shares FROM Elementary OS seems to be built in, but I don't see any "friendly" way to share out a folder.

Any suggestions?

10

You need to install samba server and make some edits in its config file:

sudo apt-get install samba samba-common

After that you have to edit the file /etc/samba/smb.conf

Just add the following (of course for requirements) to the end of the file:

[SharedFolder1]
   comment = My shared folder
   read only = yes
   path = /home/user/samba/shared_folder1
   browsable = yes
   guest ok = yes

After that you have to (re-)start the samba server:

sudo service samba restart

If the samba daemon does not automatically start on system start, type the following command:

sudo sysv-rc-conf samba on

Edit: For Loki and Juno (Ubuntu 16.04 / 18.04) the commands are:

sudo systemctl start / stop smbd for start / stop the server and sudo systemctl enable / disable smbd for autostart the daemon.

The displayed name in Windows will be "SharedFolder1".

Note: In the example above everyone has access to the folder without a password (guest ok = yes) but only in read-only mode (read-only = yes). Maybe this can also help you.

| improve this answer | |
  • now the command for restart the server is sudo service smbd restart – Thiago May 12 '18 at 22:56
  • 'sudo sysv-rc-conf samba on' doesn't work - also needs updating. – ChrisOfBristol Dec 9 '18 at 18:10
0

Try samba GUI tool system-config-samba

Check samba is installed

smbd --version

install if required

sudo apt install samba samba-common-bin

Run the following command to install it.

sudo apt install system-config-samba

Then we can start it from command line.

sudo system-config-samba

If you get the following error:

:~$ could not open configuration file `/etc/libuser.conf': No such file or directory

You can fix it by creating an empty /etc/libuser.conf file with the following touch command.

sudo touch /etc/libuser.conf

@pblakez

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.