0

I'm using elementary OS 6.1 Jólnir.
I'm trying to use chrome-remote-desktop, connecting from my Windows11 to ElementaryOS.

I have very similar symptom to this thread:
Chrome Remote Desktop not working with elementary OS 0.4.1 Loki
But the solution didn't work for me.


I installed chrome-remote-desktop service
and created .chrome-remote-desktop-session in my home directory.

/usr/share/xsessions/pantheon.desktop

[Desktop Entry]
Name=Pantheon
Comment=This session provides elementary experience
Exec=gnome-session --builtin --session=pantheon
TryExec=io.elementary.wingpanel
Icon=
DesktopNames=Pantheon
Type=Application

~/.chrome-remote-desktop-session

exec /etc/X11/Xsession 'gnome-session --builtin --session=pantheon'
DESKTOP_SESSION=pantheon
XDG_CURRENT_DESKTOP=Pantheon
XDG_RUNTIME_DIR=/run/user/1000

And when I connect to ElementryOS using https://remotedesktop.google.com/access, this blue screen pops up even after I successfully login to the server.

enter image description here

How do I fix this?


*EDIT I made some progress

  1. I gave up using custom configurations and used chrome remote desktop feature called Set up via SSH. No bluescreen problem.

  2. It still has a problem that I cannot make remote session when a local user is logged in. I want to force the local user to logout like windows remote and other VNCs usually do.

0

1 Answer 1

0

Discalimer: I would add this as a comment but I can't due to lack of reputation.

Please check the browser's DevTools (press F12) and check if there is any helpful console output or traffic messages once you connect or disconnect. Add any useful error message to your question, clearly labelling as an edit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.