I used boot-repair, but still the boot is stuck. When i use the recovery mode i cannot enter the password to decrypt the partition because the keyboard don't work. I tried all kernels and I tried 3 Keyboards, different USB Ports and i also changed the BIOS settings to legacy mode and csm and legacy USB mode but still no keyboards works to enter the password. I have a USB Stick with EOS which boots fine and in test mode i can unlock the encrypted partition. Is it possible to repair the corrupt EOS installation from outside. In other words from the terminal in test mode?

1 Answer 1


Update: I decrypted the whole partition so that i can boot at least in recovery mode but it still dont finish booting. It stops at the Busybox shell (initramfs) waiting for a command. I am a newbie and the problem started when i was tired and was trying to fix a problem where i could not update a kernel i think because the swap drive where they are stored was full of older kernels and there was no enough diskspace left for the update. The terminal gave me infos i should edit a file, which name i forgot, but something about initram. I was getting a bit impatient while reading some forumthreads about those things, and did some terminal commands trying to delete old kernels as far as i remember and since then i am unable too boot. It would be nice if someone could help me to repair the system. I backed up my files, but the environment and programs and tools i worked with would need a new setup, which would take a lot of time.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.