0

This happened after update. I'm running it on ElementaryOS 6.1.

Here's the output after I run the command flatpak run com.viber.Viber:

QIBusPlatformInputContext: invalid portal bus.
Qt: Session management error: None of the authentication protocols specified are supported
QApplication: invalid style override 'adwaita' passed, ignoring it.
Available styles: Windows, Fusion
sh: line 1: xdg-mime: command not found
qt.webenginecontext:

GLImplementation: desktop
Surface Type: OpenGL
Surface Profile: NoProfile
Surface Version: 3.1
Using Default SG Backend: yes
Using Software Dynamic GL: no
Using Angle: no

Init Parameters:

    allow-loopback-in-peer-connection
    application-name ViberPC
    autoplay-policy no-user-gesture-required
    browser-subprocess-path /app/extra/viber/libexec/QtWebEngineProcess
    disable-features DnsOverHttpsUpgrade,ConsolidatedMovementXY,InstalledApp,BackgroundFetch,WebOTP,WebPayments,WebUSB,PictureInPicture,AudioServiceOutOfProcess
    disable-setuid-sandbox
    disable-speech-api
    enable-features NetworkServiceInProcess,TracingServiceInProcess,NetworkServiceInProcess
    enable-threaded-compositing
    enable-usermedia-screen-capture
    in-process-gpu
    use-gl desktop

QQmlApplicationEngine failed to load component
qrc:/Resources/QML/MainWindow.qml: module "adwaita" is not installed
qt.core.qobject.connect: QObject::connect(QWindow, ApplicationEngine): invalid nullptr parameter

Also tried to downgrade to older flatpak versions, but there still are some issues, some are different from

1 Answer 1

1

It seemed there is a bug in QT: https://bugreports.qt.io/browse/QTBUG-99889. To launch, try the command:

env QT_STYLE_OVERRIDE= flatpak run com.viber.Viber

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.