There is a serious bug when using apt-get autoremove in freya 0.31. E.g. when installing or removing packages, apt-get will indicate packages that are no longer used and suggests to remove them with autoremove.

However, if you then use that command, apt-get will remove also packages that are still in use. When I noticed it, apt-get tried to remove Brasero. My terminal in that case looked like this:

"Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  ksh libgssdp-1.0-3 libgupnp-1.0-4 libpantheon-files-core0
  libpantheon-files-widgets0 libunique-3.0-0
Verwenden Sie »apt-get autoremove«, um sie zu entfernen." (= the following packages aren't used anymore....use "apt-get autoremove" to remove them)

When using autoremove, the packages to be removed read like this:

"Die folgenden Pakete werden ENTFERNT: (= the following packages will be removed)
  brasero brasero-cdrkit brasero-common dvd+rw-tools growisofs ksh
  libbrasero-media3-1 libburn4 libexempi3 libgail-3-0 libgssdp-1.0-3
  libgupnp-1.0-4 libisofs6 libjte1 libpantheon-files-core0
  libpantheon-files-widgets0 libtotem-plparser18 libunique-3.0-0
  libzeitgeist-1.0-1 session-migration"

Does anyone have a hint how to solve this? It seems to be a quite dangerous bug to me, as it could potentially damage your system if you're not attentive enough.

  • apt-get autoremove is used to remove packages that were automatically installed to satisfy dependencies for some package and that are no more needed. It's definitely not a bug, a bad interpretation probably. Can you paste the exact commands and responses you get? Did you add/remove any PPAs ?
    – ounos
    Commented Nov 17, 2015 at 16:21
  • I know that apt-get autoremove is supposed to remove unneeded packages only. The problem is that in my case it removed the packages for an entire application (Brasero) that in fact was needed. So I'm quite sure it is a bug. At least I wouldn't want autoremove to decide which apps to keep on my HDD ;) The command I used was just the regular "sudo apt-get autoremove". The output was what I posted above. The hint that some packages aren't needed anymore was put out while I tried to install a program (the name of which I unfortunately don't remember..) Thanks for your help!
    – deesnook
    Commented Nov 17, 2015 at 23:04
  • Oh, and I added PPAs for Google Chrome, Elementary Tweaks and LibreOffice 5
    – deesnook
    Commented Nov 17, 2015 at 23:22
  • Brasero is treated the same as any other packet. Thing is, it might have been installed as a recommendation for other software, for example gnome-desktop or so. This is more of an apt issue, you can disable this behaviour.
    – psukys
    Commented Nov 18, 2015 at 21:24
  • Thank you, I couldn't tell if Brasero had been installed as a dependency or recommendation so I was a bit surprised/confused because to me there was no apparent reason for this behavior
    – deesnook
    Commented Nov 18, 2015 at 23:17

2 Answers 2


Autoremove removes packages installed automatically for dependencies. So, if you need to keep that package, it needs to be installed itself, not as a dependency. Simply remove the package and reinstall.

It is not a bug, it's more like a design choice by the devs.

Two tips:

  1. IMHO, using a wrapper to apt-get, like aptitude or synaptic, saves a lot of headache like the one you had.

  2. That is not an elementary OS-specific question. You might have a better help if you ask in a more generic board like https://unix.stackexchange.com or askubuntu.com.

  • 1
    Thanks a lot - I couldn't tell if Brasero was installed as a dependency because I didn't specifically install it, it just came with the OS installation. But your answer makes a lot of sense to me. I thought it was elementary-specific because before I used Ubuntu and didn't come across that problem. Anyways, for new apps in the future I'll heed your advice and simply use synaptic.
    – deesnook
    Commented Nov 18, 2015 at 23:15
  • Glad I could help. Yeah, Brasero is a dependency of Nautilus. I saw you asked about it the other day. Commented Nov 19, 2015 at 0:33

I start with def of autoremove from man apt-get

          is used to remove packages that were automatically
          installed to satisfy dependencies for other packages and are now
          no longer needed.

It means the packages you have listed are dependencies and are installed to satisfy dependency of other package(s).

The reason for these packages to be listed:

You might have removed the main package which causes the installation of these packages. Now they are removing because they are unused dependencies that remain on your system.

If you want to know which package causes the installation of these dependencies use apt-cache rdepends

From man apt-cache

rdepends shows a listing of each reverse dependency a package has.

See pastebin for packages in your question.

It is clear that you might have removed nautilus. Also brasero is not in default elementary installation. (see reverse depends for brasero)

To verify all dependencies for nautilus use apt-cache depends nautilus and verify whether the packages that autoremove removing are listed or not.

For me when I run autoremove after removing nautilus I got:

The following packages will be REMOVED: 

adwaita-icon-theme apturl apturl-common brasero brasero-cdrkit
brasero-common dvd+rw-tools growisofs libbrasero-media3-1 libburn4 libisofs6
libjte1 session-migration ubuntu-mono

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.