I get error message like this

W: GPG error: http://ppa.launchpad.net trusty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY AE0A77A7BFF792D0

any solutions please...?


2 Answers 2


Open terminal and run:

The proper way to add missing keys (here AE0A77A7BFF792D0)

gpg --keyserver hkp://keyserver.ubuntu.com:80 --recv AE0A77A7BFF792D0

which retrieves the key from ubuntu key server and then

gpg --export --armor AE0A77A7BFF792D0 | sudo apt-key add -

which adds the key to apt trusted keys.

The following command also do the same but it is considered a security risk and is not recommended:

 sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys AE0A77A7BFF792D0
 sudo apt-get update


"Authentication keys" are usually obtained from the maintainer of the software repository. The public key is a string which identifies that certain repository . From the error message (NO_PUBKEY AE0A77A7BFF792D0) is missing. The command will add that key.

If you need explanation about command please refer here

Extra (but useful):

apt can only handle 40 keys in /etc/apt/trusted.gpg.d . After that from 41 key you will get the GPG error "no public key found" even if you go through all the steps to add the missing key(s). So better to limit the use of PPA's. And is the reason for @Daniel post

  • Ravan, please edit your answer to describe what those commands do and why they should be run. It's not good to ask users to run commands without explaining what they are. Commented Nov 15, 2015 at 17:13
  • I'm having the same problem but with a different url (download.01.org/gfx/ubuntu/14.04/main) I have tried your solution and the y-ppa-manager to no success. When I try to import I get "gpgkeys: key FFACA3F86663559C not found on keyserver". I should try to import the from another source? Commented Jan 26, 2017 at 12:12

You can use Y-PPA manager:

To solve this install y-ppa-manager.To install open terminal and run:

sudo add-apt-repository ppa:webupd8team/y-ppa-manager
sudo apt-get update
sudo apt-get install y-ppa-manager


command 1: Adds PPA

command 2 and 3: update and install y-ppa manager.

Now run y-ppa-manager from terminal.

When main y-ppa-manager window openend,click on Advanced

From the advaced list--> click on Try to import all missing GPG keys then click OK.

  • Wow it's works thanks all about the solution, i'll tell you if i had any problem. thanks so very much.
    – ferry
    Commented Nov 15, 2015 at 18:40
  • oh yeah one thing. yesterday i tried to removed my XDM it's work but the icon still on my desktop. how to solved it?
    – ferry
    Commented Nov 15, 2015 at 18:41
  • @ferry If solved, please accept it as answer, thank you :)
    – Ravan
    Commented Nov 16, 2015 at 2:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.