4

I installed Freya as a dual-boot to Windows. First its not working anyway so I searched the posts and get Grub repaired by purging and fixing it with Boot Repair. That let me boot into Freya some time, but now after updating Freya it will only boot into Freya in recovery mode from grub menu. Same problem is when I told Freya to hibernate it doesnt wake up, shows a blank screen as when I try to boot normal from grub. Any idea whats going wrong?

1

Boot using the recovery option in your grub. Then open a terminal window and type:

sudo nano /etc/default/grub

Add nomodeset to GRUB_CMDLINE_LINUX_DEFAULT:

It should now look like this

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
GRUB_CMDLINE_LINUX=""

Save it with Ctrl+o then exit with Ctrl+x

Then update your grub using sudo update-grub

Now you'll be able to boot without having to select the recovery option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.