1

I have an old laptop here (HP ProBook from 2014) and have been using ElementaryOS on it since I bought it. Today I installed EOS 6.1 on it. I had a couple of problems during installation (used custom partitions and forgot the /boot partition), but now I have a running system. However, the built-in wifi does not work. It does not show up in the network settings, only ethernet, vpn, proxy. I tried with my wifi usb stick and that worked out of the box. But I need that for my computer, so the laptop has to use its own wifi card. It did work before with EOS Hera 5.1.

A couple of random pieces of information:

It's not a dual boot. It's UEFI.

Before I used only one partition, this time I wanted to separate data from OS, so I put /home on its own partition.

The built-in wifi card is a Broadcom BCM43228. Kernel module is "bcma".

I ran apt update and apt dist-upgrade already and restarted after that. No change.

I followed some tutorials on the internet and they suggested to install additional drivers (bwml-source something). I did that and during installation they did a modprobe and told me "module wl not found".

rfkill list all returns nothing.

Any ideas? I thought hardware support would be no problem on such an old, but not ancient machine...

Update August 2023:

This problem is still persistent (I recently tried it again). Newer ElementaryOS distributions seem to have a lot of strange problems with wifi connections.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.