4

I can't get sound to work on HDMI. I've read every thread on it I found, tried everything and nothing seems to work.

When I connect the HDMI cable to my tv (which btw had no problems with hdmi sound prior to this, whether with my ps4 or windows) the screen duplicates or extends to the tv randomly, which is weird but unimportant. Unlike other distros I tried where mouse started to lag, on elementary there's no issues with HDMI other than the apparent lack of sound.

I've tried downloading pavucontrol, I've tried updating alsa, I've tried every nvidia driver I found, but nothing I do changes anything in the sound options. I still only get the choice between speakers and digital s/pdif.

I'm using an older laptop with second generation i7 CPU 6gb of ram, an integrated Intel graphics card and a GT 635M.

  • I have the same issue. And there is no the HDMI output in profile list. Still no resolve.. – Nikita Khoroshun Jan 6 '17 at 23:22
  • I have the same issue and have tried everything here too: itsfoss.com/… – AndrewVos Jul 5 '17 at 10:12
2

Go to: system settings > sound. in Profile select HDMI output

0

I have this problem too, and thought it was related to my BIOS firmware so I updated that. Still no sound.

I installed Ubuntu 16.04.2 and HDMI sound works. I'm guessing some package needs to be updated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.