0

Is it possible to install elementary OS on a flash drive without loading a bootloader for a Mac?

Create a live drive with the latest version of elementary. I proceeded to form another drive with 200 mb for an EFI partition and the rest for an ext4 with root.

Since I did not find in the new installer io.elementary.installer the option to not install bootloader, I opened a terminal console and ran:

sudo apt get ubiquity

Then I ran the ubiquity as installer with the no bootloader option

ubiquity -b

I managed to install elementary completely on my USB and then I installed refind on the EFI partition following this procedure:

We will be using a super awesome 3rd party boot manager rEFInd. It can detect any operating systems installed in EFI mode and boot them.

Download rEFInd zip and extract it Open Terminal and navigate to rEFInd directory Run diskutil list and find the name of your flash drive’s EFI partition. (In my case /dev/disk2s1) Run ./refind-install --usedefault /dev/diskXXX (replace XXX with appropriate name)

Then I rebooted and pressed the option key to boot the efi drive which ran the refind and I was able to boot the system, but I always got the password error. I repeated the process several times and it always gave a password error. It was not the keyboard layout, I even tried with the on screen keyboard.

Is there any way to install and boot an elementary OS on a Mac flash drive or should I move to Ubuntu?

I'm not talking about lives with persistence

Thanks

1 Answer 1

0

I don't have an answer, but I am trying to accomplish same thing you are on a 2016 macbook.

Did you use etcher to create the elementary install drive? If so, you might try creating one with unetbootin.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.