0

I tried to install elementary-tweaks to change some of the themes in Elementary OS 6.1. Method I used must not work for 6.1 or I do not fully understand how to implement it yet. Now when Install anything I get the following message.

To fix i tried running "sudo apt-get clean && sudo apt-get -f install", but I get the same message when trying to install again. Anyway to remove this package so I can install again?

Appreciate the help!

ThinkPadT430:~$ sudo apt install Reading package lists... Done Building dependency tree
Reading state information... Done You might want to run 'apt --fix-broken install' to correct these. The following packages have unmet dependencies: elementary-tweaks : Depends: libgranite5 (>= 0.2.0) but it is not installed E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution). ThinkPadT430:~$ sudo apt-get clean && sudo apt-get -f install Reading package lists... Done Building dependency tree
Reading state information... Done Correcting dependencies... Done The following additional packages will be installed: libgranite5 The following NEW packages will be installed: libgranite5 0 upgraded, 1 newly installed, 0 to remove and 3 not upgraded. 1 not fully installed or removed. Need to get 167 kB of archives. After this operation, 650 kB of additional disk space will be used. Do you want to continue? [Y/n] y Get:1 http://mirrors.ubuntu.com/mirrors.txt Mirrorlist [3,335 B] Get:2 http://archive.ubuntu.com/ubuntu focal/universe amd64 libgranite5 amd64 5.3.0-1 [167 kB] Fetched 170 kB in 1s (125 kB/s)
(Reading database ... 112490 files and directories currently installed.) Preparing to unpack .../libgranite5_5.3.0-1_amd64.deb ... Unpacking libgranite5:amd64 (5.3.0-1) ... dpkg: error processing archive /var/cache/apt/archives/libgranite5_5.3.0-1_amd64.deb (--unpack): trying to overwrite '/usr/share/metainfo/granite.appdata.xml', which is also in package libgranite-common 6.2.0+r2223+pkg122~ubuntu6.1 Errors were encountered while processing: /var/cache/apt/archives/libgranite5_5.3.0-1_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1) ThinkPadT430:~$ sudo apt install Reading package lists... Done Building dependency tree
Reading state information... Done You might want to run 'apt --fix-broken install' to correct these. The following packages have unmet dependencies: elementary-tweaks : Depends: libgranite5 (>= 0.2.0) but it is not installed E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

0

2 Answers 2

0

After sharpening my search skills I found the below solved my issue!

sudo apt remove elementary-tweaks

1
0

The sudo apt remove elementary-tweaks seemd to solve the problem for me too!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.