0

So one of the first things I tried to do with my fresh install of Elementary OS turned out to be a noob mistake. I followed a youtube tutorial to install Elementary Tweaks only to learn that it's not compatible with Odin. I should have installed Pantheon Tweaks instead.

So I follow the instructions to do that and it says missing dependencies. "libgranite5" and "libpantheon-files-core0" to be exact. But when I try to "sudo apt-get install" those they return "E: Unable to locate package". So now I'm stumped.

1 Answer 1

0

I can help you with the elementary-tweaks issue, it won't work on Odin/Jólnir, you'll have to install pantheon-tweaks. Here you can find how to install it: https://github.com/pantheon-tweaks/pantheon-tweaks

7
  • I tried that. it returns: The following packages have unmet dependencies: elementary-tweaks : Depends: libgranite5 (>= 0.2.0) but it is not going to be installed pantheon-files : Depends: libpantheon-files-core0 (= 6.1.1+r5124+pkg110~ubuntu6.1) but 6.1.0+r5055+pkg107~ubuntu6.1 is to be installed E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution). Dec 18, 2021 at 18:16
  • Try sudo apt purge elementary-tweaks
    – user26849
    Dec 18, 2021 at 19:24
  • ^ purge did not work. The following packages have unmet dependencies: pantheon-files : Depends: libpantheon-files-core0 (= 6.1.1+r5124+pkg110~ubuntu6.1) but 6.1.0+r5055+pkg107~ubuntu6.1 is to be installed E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution). Dec 18, 2021 at 19:40
  • It seems that you have an issue with the pantheon-files. Try to purge and reinstall that package. For some reason, you're not getting the latest version, which currently is 6.1.1+r5124+pkg110~ubuntu6.1. Also check your repositories and remove and daily versions.
    – user26849
    Dec 19, 2021 at 7:26
  • guess what? I can't purge pantheon-files because of the missing libgranite5 dependencies! It's like a chicken and egg problem. At this point I'm considering a fresh reinstall. Dec 19, 2021 at 16:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.