0

App Centre shows 1 update: org.gnome.Platform Flatpak runtime

It fails to install through app centre or the terminal with flatpak update command.

Originally there were 4 flatpak apps that would not update, I, probably foolishly, uninstalled the other 3 through the app centre, if I now attempt to reinstall them they give error message and do not install.

Having read through various potential solutions the information below shows the current output when flatpak update is run in terminal.

~$ flatpak update
Looking for updates…
Info: (pinned) org.freedesktop.Platform//19.08 is end-of-life, with reason:
   The Freedesktop SDK 19.08 runtime is no longer supported as of September 1, 2021. Please ask your application developer to migrate to a supported version
Info: org.freedesktop.Platform.GL.default//19.08 is end-of-life, with reason:
   The Freedesktop SDK 19.08 runtime is no longer supported as of September 1, 2021. Please ask your application developer to migrate to a supported version
        ID                          Branch         Op         Remote          Download
 1. [✗] org.gnome.Platform          40             u          flathub         1.0 kB / 365.3 MB
Error: While trying to checkout
    87a6c4d375b853befc4e887d73a26dd10c4e537c36c425a6ecfaf2993324afa4 into
    /home/ckinren/.local/share/flatpak/runtime/org.gnome.Platform/x86_64/40/.
    87a6c4d375b853befc4e887d73a26dd10c4e537c36c425a6ecfaf2993324afa4-DDT2D1: 
    Opening content object 
    21dcb38ea666822fa75761faa634282edffaa546545b70d8d8645f1c0104e01c: 
    Couldn't find file object 
    '21dcb38ea666822fa75761faa634282edffaa546545b70d8d8645f1c0104e01c'
Updates complete.
error: There were one or more errors

From flatpak list the org.freedesktop.Platform that is at 19.08 appears to be a system installation.

Is anyone else experiencing the same or similar problems? Are there any solutions?

1
  • Which version of Elementary OS are you running? The message shows that the version of org.freedesktop.Platform that you're running is end-of-life, meaning that it may not be able to work with the newer Flatpak server APIs. It also seems to be pinned, which means there's a hold on the package to prevent it from being updated, exacerbating the issue ... 🤔
    – matigo
    Dec 9, 2021 at 0:19

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.