0

RESOLVED!! Sorry I'm so new that I don't know how to mark an issue resolved, but matigo's answer definitely resolved my issue. This is no longer a question now that matigo has stepped in, so it is completely resolved and needs to be marked that way, if a mod reads this and cares to, for everyone else's sake. Thanks!


I'm still a new eOS user. I've had to reinstall a couple of times for various reasons, and I remember in the past I found a way to do this, but this time I can't and I was hoping for your help.

When I choose Shutdown from the power button on the right side of the panel, I want it to reboot immediately without asking any questions, like "Are you sure you want to." :) I used to have it doing that, but this time I can't find a way to get it setup right. It would do just that: I chose Shutdown and the system immediately reboots - not shuts down, reboots.

That's perfect for me because I leave my machine on all the time and I have a Windows partition that I reboot to a few times a day. Beyond that, I'm currently making a lot of system changes and that means I'm constantly rebooting to make whatever change I'm working on take effect.

I could use like a script that has an icon on my Plank for that, but I'd prefer not to as my Plank is already kinda full. :) So yes, I'm fully aware of shutdown -r now but I don't want to implement that - I'd rather stick with the Panel since it's already in place and I have done this before - recently, on eOS 6 Odin. I'm thinking I might have somehow installed Elementary Tweaks on my first try, and maybe it was included in there. I now have Pantheon Tweaks (like I'm supposed to) but I don't see an option in there for that, or anywhere else in the system's configuration.

Oh, and yes, I have googled this to death, for Pantheon, elementary OS, and Ubuntu. I just can't find a way to do it again.

Your assistance and guidance are immeasurable and greatly appreciated. I'm keeping a record of everything I do to the system now, so it won't go unforgotten. Thank you for your time and attention.

1 Answer 1

0

You can disable the confirmation dialog by typing this into Terminal:

gsettings set org.gnome.SessionManager logout-prompt false

Interestingly, after doing this on my Elementary OS 6 installation, the machine will reboot instead of shutting down. So this may kill two birds with the same stone for you.

If you would like to revert the change, you can restore the original setting by changing false to true:

gsettings set org.gnome.SessionManager logout-prompt true
2
  • Ah, cool! Thanks so much! I haven't tested it out yet, but that sounds like exactly what I want. I'm in the middle of going through some old media right now so can't reboot to test, but I'm sure this is exactly what I wanted. I'll mark this as resolved after I have a chance to check it out later, but I'm really sure this is precisely what I wanted. Thanks a bunch, matigo!
    – Unknowable
    Commented Dec 3, 2021 at 2:59
  • Yes, that did it perfectly! That is exactly what I wanted - IMMEDIATE reboot with no questions. I've always hated being asked if I was sure I wanted to do things on the computer, this makes my life that much easier. Thanks again, matigo!
    – Unknowable
    Commented Dec 3, 2021 at 5:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.