0

I've just install elementary Odin on my laptop for the second time. Each time everythings is working well, internet (wifi and ethernet) is working smoothly. But for the second time 24-48h hours after elementary install, I have no more internet :

  • Wifi is activate and connected
  • Ethernet works
  • but not internet connection when I ping google.com or try to open Firefox, neither when I tried upgrade or update.

I didn't change any network configuration this elementary install. I've tried several possibilities : restart network manager (don't work), re-install elementary (works for some times), and I don't see how to diagnosis this problem. I've checked network manager, hardware configuration and material. Can somebody help me to diagnos and correct my problem ?

Cheers

1
  • Could you post the Terminal output of the following commands: (1) sudo lshw -c network (2) sudo lspci. This will show hardware-specific information about your computer. Does the network connection drop after the computer sleeps?
    – matigo
    Nov 22 '21 at 10:01
0

Found a solution to my own problem with a friend's help, seems to be a DNS configuration anomaly. Ping 8.8.8.8 works so I had "nameserver 8.8.8.8" in /etc/resolve.conf file and set ipv4 Method to "automatic address only (DHCP)".

But still, I don't understand why this append and I'm not sure this solution is stable or the best one.

Can somebody tell me what would be the more stable and best solution ?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.