0

I turn on my PC and greet with the login screen. I type in my password. It takes 30-60 seconds before the wallpaper, dock and panel to show up. Before the last update (fresh installs), the desktop, docks, wallpaper, panel all loaded in 1 second.

Does anyone have any ideas what causing this?

Specs:
OS: Elementary OS 6 Odin
Motherboard: Asrock X300    
CPU: Ryzen 5 3400G
RAM: 2x8 GB DDR4-3200 MHz 
Storage: Samsung P981a SSD NVMe

I'm not sure if this is a duplicate issue. I have read the old archive answer related to dbus

A solution (or at least temporary workaround) proposed in the bug discussion - https://bugs.launchpad.net/elementaryos/+bug/1596377 - is to rename the file:

/etc/xdg/autostart/at-spi-dbus-bus.desktop

to

/etc/xdg/autostart/at-spi-dbus-bus.disabled

This fixed it immediately for me.

I will test it tomorrow and come back with an update.

Update 1: Listening to Maccer's suggestion. Here is the output on systemd-analyze critical-chain

x300@X300:~$ systemd-analyze critical-chain
The time when unit became active or started is printed after the "@" character.
The time the unit took to start is printed after the "+" character.

graphical.target @7.213s
└─multi-user.target @7.212s
  └─hddtemp.service @7.188s +23ms
    └─network-online.target @7.187s
      └─NetworkManager-wait-online.service @1.137s +6.049s
        └─NetworkManager.service @987ms +147ms
          └─dbus.service @985ms
            └─basic.target @978ms
              └─sockets.target @978ms
                └─snapd.socket @977ms +533us
                  └─sysinit.target @974ms
                    └─snapd.apparmor.service @918ms +55ms
                      └─apparmor.service @889ms +28ms
                        └─local-fs.target @888ms
                          └─run-user-1000-doc.mount @10.696s
                            └─run-user-1000.mount @9.126s
                              └─swap.target @683ms
                                └─dev-mapper-cryptswap.swap @643ms +38ms
                                  └─dev-mapper-cryptswap.device @642ms
3
  • 1
    To know what's affecting boot time: systemd-analyze critical-chain. In red you will see what services are increasing your boot time and by how much. To disable one systemctl disable nameof.service. That thing you have disabled affects the screen reader (text to voice, it's an accessibility feature) so unless you use that it should be okay.
    – Maccer
    Oct 24 at 15:44
  • Have you fixed it yet? I've the same problem now
    – M. T.
    Oct 27 at 16:03
  • Nope, I can only show the output. I disabled all snapd related .service. It reduced the time down to 12s (instead of 27s). But the time is still too long. The black screen is still there. I'm looking for a way to prioritize the desktop loading .service.
    – Jake
    Oct 29 at 1:12
0

This issue was mentioned on Github and an update from elementary has been pushed out to resolve this issue. Update your system through AppCenter and the issue should be resolved!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.