0

After upgrading the Kernel to 5.11.0-37-generic, I cannot access the Elementary OS login screen whenever restarted.

I will need to reboot the PC a couple of times before accessing the Elementary OS login screen.

Also, in the new Elementary OS, there is no way to select the Kernel version. For example, if I want to boot with the previous Kernel, there is no option. I have tried using the Grub Customizer to manage the boot menu, but this doesn't seem to work.

Is there any workaround for this?

7
  • Older kernels should be available inside "Other options for elementary" in the grub menu. How did you install that kernel? Did you install anything else? What graphics card and cpu do you have?
    – Maccer
    Oct 17 at 10:53
  • I made a clean installation for Elementary OS 6, i.e. after doing a full re-format of my disk. The Kernels were updated when the default os update was done, i.e. using sudo apt-get update. CPU Details: Hexa-Core Intel® Core™ i7-5820K CPU @ 3.30GHz Graphics Card: NVIDIA® GeForce® GTX® 1050 Ti Oct 18 at 11:57
  • Press Ctrl + Alt + F1 and login in the screen that appears. Then type sudo ubuntu-drivers autoinstall to be sure you have the graphics driver installed. Also, how did you install that kernel? The best way is using sudo apt install --install-recommends linux-generic-hwe-20.04 to make sure the ubuntu patches are applied.
    – Maccer
    Oct 18 at 21:32
  • The kernel was installed when I did the sudo apt-get upgrade. All the libraries, software and kernels were upgraded to the latest version provided. Oct 19 at 4:57
  • That's strange. Because that kernel version is the HWE version and not the default. Let me know if the other command solved the issue!
    – Maccer
    Oct 19 at 13:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.