0

Have created mount point:

enter image description here

Followed by line added to fstab:

enter image description here

and restarted PC, but... instead of my share being connected I get this:

enter image description here

What is going on? please

I have no problem seeing the share as root,

I can connect as a user supplying pasword via network,

but if I try use to open Devices I get this:

enter image description here

LATER EDIT it would seem that this issue is related to a problem I had before:

permissions issue for email folder stored on NAS

I now can mount NAS drive in elementary OS 6 but for some reason everything still remains owned by ROOT

Attempts to chown so far un-succesful (i.e. I can chown anything/everything apart from the mount point)

This whole experience of using network drives in Linux (and in particular in elementary OS - I didn't have these kind of problems with other distros) is very frustrating.

I am still not sorted out ....

4
  • Are you able to mount the location without using fstab and work with the files properly?
    – matigo
    Oct 15 at 1:43
  • I can see network drives and can get into them manually no problem
    – bambuko
    Oct 15 at 6:29
  • I can confirm, that I can mount NAS drive either manually or using fstab. Both work fine. The issue is that after mounting, when I try to open it I get this message - "The Folder Does Not Belong to You, Tou don't have permission to view this folder" I will try to investigate whether there is some problem at Synology end? (but why? it all works fine when I run things in elementary as an administrator...)
    – bambuko
    Oct 15 at 7:20
  • I have now tested it in elementary 6 Odin as well and the same result (with slightly different error message): "Error mounting volume" "mount:/media/My_Files_CK: operation permitted for root only"
    – bambuko
    Oct 15 at 11:30
0

after three days ... :-)

I think I have found a solution. It is here:

https://ubuntuforums.org/showthread.php?t=288534

If you look down to the bottom of the post, you will find (in Troubleshooting)

Files owned by root / "The folder contents could not be displayed". If you can view but not change, delete, or add new files to your Samba share, or if you get an error in Nautilus which says, "The folder contents could not be displayed" or more recently "You don't have permission to do that"; try this fix:

Add gid, uid, and nounix options to your fstab line like so:

//netbiosname/sharename    /media/sharename        cifs    credentials=/root/.smbcredentials,iocharset=utf8,gid=1000,uid=1000,nounix,file_mode=0777,dir_mode=0777 0 0

works fine in both Hera and Odin

Happy days, at last...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.