0

I tried to connect my Android device Redmi Note 9 Pro via USB cable to my laptop (HP laptop, 4GB RAM, Dual-Core Intel® Core™ i3-5005U CPU @ 2.00GHz) which has elementary OS Odin as host OS, but it is showing me this error:

Unable to Show Folder
The server for this folder could not be located.

The specified location is not mounted

Original screenshot

I thought it might be an issue with some packages, so I searched through the internet, and for most of the websites I found, the solution is to install libmtp and mtpfs. I installed libmtp and when I tried to install mtpfs, it is showing me unable to locate package mtpfs.

Also, when I tried to connect my other two Android mobiles, it simply mounted normally without any problem (I can access files and folders of the Android device).

Also, my Android mobile (Redmi Node 9 Pro) is accessible (normally mounting) in Ubuntu 20.04 LTS along with the other two devices.

I am attaching the error message which might help you to figure out the problem:

home@HomeHP:~$ mtp-detect
libmtp version: 1.1.17

Listing raw device(s)
Device 0 (VID=2717 and PID=ff40) is a Xiaomi Mi-2s (id2) (MTP).
   Found 1 device(s):
   Xiaomi: Mi-2s (id2) (MTP) (2717:ff40) @ bus 2, dev 18
Attempting to connect device(s)
error returned by libusb_claim_interface() = -6LIBMTP PANIC: Unable to initialize device
Unable to open raw device 0
OK.
home@HomeHP:~$

Original screenshot

I don't know what is the problem, please help me out.

4
  • Do you see anything in /var/log/syslog at the time you connect the phone that might explain the issue? 🤔
    – matigo
    Oct 13, 2021 at 12:29
  • did you unlock the screenlock? Also enable mtp in your phone?
    – HeArch3
    Oct 13, 2021 at 22:30
  • yes, I opened the syslog file it is mostly showing me the details of my mobile (serial number , ids , manufactures etc) but this was the line which was failed "Oct 14 08:48:36 HomeHP io.elementary.f[7636]: files_file_set_expanded: assertion 'self->is_directory' failed"
    – Noob_coder
    Oct 14, 2021 at 3:24
  • Of course, My screen is unlocked and I always select File transfer/Android Auto when prompted after connecting usb.
    – Noob_coder
    Oct 14, 2021 at 3:32

1 Answer 1

0

I'm using Android File Transfer (https://github.com/whoozle/android-file-transfer-linux). I didn't have to in Hera but now I have the same issues as you have with, coincidently, my Xiaomi Redmi Note 9 Pro.

1
  • Thanks I can now access the files of my Android device using Android file transfer. Though my problem was not solved, but this is also good for transfering files from android device.
    – Noob_coder
    Oct 14, 2021 at 3:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.