0

I have LDAP running successfully and can log in successfully as an LDAP user either from tty or Terminal after logging in as another user. How can I log into the graphical environment as an LDAP user?

My default admin account and a local, standard account for testing both appear on the Greeter screen after boot but LDAP users don't.

My preference is to display only LDAP users who have already logged in on the machine and have a home directory rather than every user in LDAP.

2
  • Are you not able to log in with the LDAP credentials themselves? Generally the login mechanism will first check for a local account and, if that doesn't exist, will try other authentication providers automagically 🤔
    – matigo
    Oct 6 at 5:07
  • Thanks for the response. I can log in as long as I can enter the user name but there is no way to add a username on the welcome screen. It displays the two local users only (the admin account and a standard account for testing). I need some way to either have ldap users displayed on the welcome screen or an "other" option so that I can enter both the username and the password. I wondered if it might be possible using io.elementary.greeter.conf or users.conf in /etc/lightdm/ but can't find any documentation on those files nor any clues in the files themselves. Oct 6 at 8:27
0

You will need to create a custom configuration file to accomplish this goal.

Here's how you do it:

  1. Open Terminal (if it's not already open)
  2. Create a new directory for some LightDM configurations (if it doesn't already exist):
    sudo mkdir /etc/lightdm/lightdm.conf.d
    
  3. Create a custom configuration file:
    sudo vi /etc/lightdm/lightdm.conf.d/50-custom.conf
    
  4. Paste the following into the new file:
    [SeatDefaults]
    greeter-show-manual-login=true
    allow-guest=false
    
  5. Restart LightDM:
    sudo service lightdm restart
    

You will now see a "Manual Login" option at the bottom of the screen:

Manual Login

Click on that and ...

Done

There you go 👍🏻

1
  • Thank you. This does just what I want. Oct 6 at 9:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.