I've tried to install elementary OS alongside Windows 10 in a UEFI machine. I first did it with Secure Boot enabled, using the "something more" option. I created the boot, root and swap partitions as I always do. But the strange thing is, when the installation ended and the machine was rebooted, Grub did not showed up and Windows was loaded instead. Then I retried disabling Secure Boot, and the same thing happened, so I loaded the live CD and reinstalled and updated grub from a chrooted partition as seen here: same result. I get the same results with Ubuntu 15.10. Same thing trying the option "Install alongside Windows" instead of "Something more".

After that, I followed this tutorial with no luck. Basically, I disabled Secure Boot and Fast Startup, created all neccessary partitions and installed elementary. No repairing tools like EasyBCD or Boot Manager have been useful so far.

Can someone point me in the rigth direction? What am I missing here?

My machine is an Alienware X51 R3 with a Samsung’s PM851 M.2 SSD and Windows 10 installed. I have previously succeded double-booting Windows 10 + Elementary OS in an Alienware X51 R2 and a Samsung EVO 840 SSD.

  • 1
    Possible duplicate of Cannot boot Freya after installing alongside Windows on UEFI – Daniel Foré Nov 12 '15 at 20:30
  • The proposed solution has not worked for me. I just can't make Grub show up. In fact, in BIOS no bootloader other than Windows Boot manager appears to select. – derkomai Nov 16 '15 at 21:38
  • 1
    please refer here and let me know =) – Ravan Nov 18 '15 at 2:32
  • Ok, so I'm having some trouble while trying to reinstall GRUB doing "sudo mount /dev/sd*** /mnt". My system recognizes the ssd drive as nvme01n1, and the system partition is located under /dev/nvme01n1p8. I can clearly see it there, but "sudo mount /dev/nvme01n1p8 /mnt" will yield "mount: special device does not exist". – derkomai Nov 18 '15 at 20:22
  • Furthermore, should I install the bootloader onto /dev/nvme0n1p06 (the partition I created for /boot) or directly specify the device /dev/nvme0n1? I guess It's the first option, despite I've already tried both with the same results. And should I create the /boot partition anyway? – derkomai Nov 19 '15 at 10:34

Since the previous method not solved, this is the possible solution:

Steps:

  1. Boot into windows and open command prompt as administrator, and run the command to disable hibernation

    powercfg /h off 
    
  2. Disable Fast Boot,

    Control Panel --> select the Energy Settings-->enable show hidden settings -->uncheck Fast Boot ( this is the path in older systems)

  3. Now shutdown completely

  4. Now boot from elementary live usb/cd (select Try elementary )

  5. Open terminal and run the commands:

    sudo mount [1] /mnt
    sudo mount [2] /mnt/boot/efi
    for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
    sudo chroot /mnt
    grub-install [3]
    update-grub 
    

    Note:

    [1]=system partition ; [2]=efi partition; [3]=disk

    Use gparted to identify partitions

Finally, Boot into BIOS and change the boot order in UEFI settings. Select elementary to be the default operating system to boot.

reference here

  • In the BIOS, the only options in the boot priority menu are: Hard disk: Windows boot manager, USB, CD/DVD, Floppy, Network adn Disabled. No entry for elementary. – derkomai Nov 10 '15 at 16:12
  • select windows boot manager and hit enter-- let me know the result =) – Ravan Nov 10 '15 at 16:15
  • It justs selects windows boot manager and nothing happens. No othe options appear. – derkomai Nov 10 '15 at 20:32

Try to delete all swap and ext4 partitions and leave them as "unallocated", delete all linux&grub&ubuntu folders from the efi boot partition (but NOT the partition), boot to Windows, use Visual BCD edit to again erase all traces of grub&ubuntu from the boot menu.

Now when re-installing elementary, choose "alongside Windows" option if it appears, if not, then manually partition, but root and swap only.

When you boot into a grub shell, then read this How can I fix a secure boot failing to grub when I installed 0.3.1?

up vote 0 down vote accepted

Finally, I made it using rEFInd. I guess it could be done as well with GRUB, but it was only while reading the rEFInd documentation when I understood what was happening.

It seems that, depending on the hardware vendor (mine is Dell/Alienware), some machines will search for microsoft's bootmgfw.efi exclusively instead of the general bootx64.efi. So it does not matter if Grub is installed correctly, it will not boot. The steps to solve this are described here, and basically they consist in renaming elementary's bootx64.efi and replacing Microsoft's bootmgfw.efi with it.

I also deactivated secure boot, fast boot and automatic boot repair. This last one is done by typing in a windows admin shell:

bcdedit /set {current} recoveryenabled No

I guess this makes me to give a kudo to the blueprint to ditch grub for rEFInd.

I had this problem. In my experience, it was because I chose advanced partitioning and then made my partitions how I wanted.

If you forget to create an EFI system partition (about 100Mb is needed), then it appears not to install the bootloader and the bios has no knowledge of Elementary.

The solution was to re-install and ensure to create an EFI system partition, and after install, set "ubuntu" as the preferred boot device in my bios. Grub then gives me the option of either Elementary or Windows at startup.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.