2

I'm new to Elementary OS. I would like to type in Japanese, but I can't figure it out. I can add the option in iBus to switch to Japanese, but then it still just prints out roman characters. Plus, with iBus, every time I log in to Elementary OS, I need to go into settings and activate iBus again. And it doesn't let me switch the keyboards with Cntrl+Space - even though I have it configured it that way in the settings. Is there an iBus alternative that works with Elementary OS 6? I've looked on the internet for other answers, but all the other help topics I've been able to find are for previous versions of Elementary OS, and don't appear to work now (like this one: How can I enable Japanese input?).

Any help would be great. Thank you!

2 Answers 2

2

The best way to type in Japanese on Linux in my experience is to use the mozc input method. It's hidden a little bit in Elementary OS 6, but this is how you can get it working:

  1. Open "System Settings" and go to "Keyboard"

  2. Under "Layout", make sure the left-most list has the keyboard layouts that you have installed. I am using a Japanese keyboard, so only that one is listed. Keyboard — Layout

  3. Under "Input Method", enable IBus (if it has disabled itself again for you)

  4. Click the + button under the list of layouts (on the left-hand side) and filter on "Japanese": Keyboard — Input Method

  5. Click on "Japanese — Mozc", then click "Add Engine"

  6. You will now see in the upper-right corner a little widget with a capital letter "A":

    The Mozc Widget

    This is how you can change your input going forward.

    Note: If you do not see the little widget, click "Japanese — Mozc" in the settings or, set the language bar in the upper-right corner.

    Language Bar

  7. Open any text editor you wish

  8. Ensure the little Mozc widget is set to the input that you would like: Mozc Widget — Input Type

  9. Give it a test: What's This?

When this is all said and done, the Input Method is remembered across reboots. You will not need to reconfigure, reinstall, or rejigger anything.

Note: You may want to also confirm that you have the Japanese language packs fully installed. This will ensure the autocomplete dictionaries are in place as well as a couple of decent fonts. This can be done in the "Language & Region" section of the system settings. Select 日本語 and just hit "Set Language". This will not change the language of Elementary, but will instead confirm that everything has been installed.

Language & Region — 日本語

2
  • Thanks matigo for that detailed response! I just followed your instructions, and it is working now it appears. However, whenever I log out, I still have to go into keyboard settings and restart the iBus Daemon. Is there a way to have it start automatically when I log in?
    – Link1600
    Oct 4, 2021 at 20:40
  • Okay, I tried it again on a different computer, and I was able to get the "ja" and the widget to show up, but when I type, it just inserts romanji characters. I set the input method to hiragana in the widget. Any ideas as to what I'm doing wrong?
    – Link1600
    Oct 6, 2021 at 5:10
0

It might be worth noting that you can't add the Mozc engine if your display language is set to Japanese (or at least I have not been able to find a way to do it). If you want the GUI to be Japanese you need to set the keyboard before changing the display language.

It seems illogical but there is no input method engine available by default when the display language is set to a language which needs it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.