0

I installed the loki app which is the best minimalist viewer today (it can display gif/jpg and webm files, no other viewer can). [https://lowkeyviewer.com/ if you want to ckeck it out]

However now Elementary wants to install this update:

loki MCMC linkage analysis on general pedigrees Version: 2.4.7.4-10

This conflicts with the app that's why I uninstalled that "loki MCMC linkage whatever it is" first.

I'm happy to skip updates forever, no way I'm giving up such a good viewer.

What can I do? Is there any other alternative? Can I change the name of the loki viewer to something else? I'm not a developer, I only cloned the git hub, run yarn and installed the loki .deb

3
  • By the way, I have reported this issue to the developer.
    – G Durand
    Sep 26 at 19:44
  • How did you install the application? Depending on the method, you should be able to "pin" your installed version so that it is not replaced.
    – matigo
    Sep 27 at 8:51
  • Hi @matigo I just used the gdebi installer and installed the .deb file. I had to uninstall the "loki MCMC linkage analysis on general pedigrees" using synaptics. thanks for your suggestion, going to explore it.
    – G Durand
    Sep 29 at 18:20
0

The problem was solved by locking the package. First in Synaptic by locking the package. Then in the Terminal with:

sudo apt-mark hold loki

Then again with dpkg for good measure:

echo "loki hold" | sudo dpkg --set-selections

Now I can run all Elementary updates and my LowKey Viewer works like a dream. This solution is based on this Linux Uprising post.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.