1

I have been using elementary OS 6 since it got released without many issues.

I updated the system through the app center yesterday, and was prompted to reboot.

After rebooting, the greeter goes into a loop. I can't log in, it just keeps flashing and starting up again. I barely see my user account and the mouse cursor for a second before it starts up again (basically flashes black, and then I see the top bar and a second later, I see my user account, then it goes black again)

I can't even go into TTY and log into my user account through the CLI. When I hit ctrl + alt + F7, I see the CLI login prompt for a second and then I am immediately taken back to the greeter where I see the same loop.

I tried the following so far.

I booted into a recovery kernel and dropped down to root shell, then I uninstalled the NVIDIA graphics driver by running apt-get remove --purge nvidia-*

This did not help. The only differences now are that the time I see the greeter top bar before it loops again is shorter, and I don't see the user account anymore; it flashes black and loops directly after the top bar appears.

important details

  • I hadn't updated since two weeks before updating yesterday because I haven't used the laptop since a while, so there was a load of new OS updates.

  • the laptop has an NVIDIA GeForce GTX 1070 GPU

  • It's not a hardware problem because I successfully booted into a live boot session of Ubuntu through a USB thumb drive with Ubuntu 20.04 burnt on it

2
  • 1
    As a temporary solution, I dropped down to root shell from the recovery kernel, uninstalled the greeter by running apt-get remove --purge io.elementary.greeter and installed lightdm. At least I can use my OS now, but I want to go back to the EOS greeter because it's much nicer Sep 25 at 9:13
  • I have a similar issue. I get to the screen where accessibility, wifi and power icons show up but no username and password prompt. If I go to console with ctrl+alt+F2, I can use it for around 30s and then it takes me back to that empty screen. Cursor does not show but I can click to the icons. Every couple of restarts it worked normally. I switched to lightdm for now.
    – tkowal
    Oct 3 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.