0

enter image description hereHow do I get past this error gpio_aaeon? I am trying to boot into a live USB of Elementary OS v -6.0-stable.202108 on a R7 5800X , 6700XT b550-a strix

0

The gpio_aaeon driver was added in more recent kernel versions. You would need to update the kernel after installing elementary with sudo apt install linux-generic-hwe-20.04

To solve it until you install elementary, you need to press e when the "Install elementary" grub prompt appears and go to the line that says quiet splash and write instead quiet modprobe.blacklist=gpio_aaeon splash. Then you can continue to boot the system.

6
  • Now I get igc 0000:0a:00.0: no suspend buffer for PTM ; I tried a modprobe.blacklist:amdgpu and it booted to a screen that said Elementary OS Next Elementary Login: then asked me for a login and password. I booted the same key on my laptop and it went straight in. Is the kernel outdated? It seems to not like my hardware
    – circlol
    Sep 25 at 3:13
  • Your hardware was introduced to market last year, wasn't it? Since most manufacturers don't care about linux, the support for new hardware is slow. It may take until the next elementary version that you have good support out of the box. We can work around that, but it would mean a bit of tinkering.
    – Maccer
    Sep 25 at 8:15
  • Regarding your new issue. Do you have anything else installed on this disk? Are you booting in Legacy or UEFI mode? Do you have secureboot enabled/disabled?
    – Maccer
    Sep 25 at 8:16
  • i figured it could've been a compatibility, it would make sense. The flash drive was has been reformatted with a stock image, I have tried booting with CSM enabled, disabled, booting into the legacy version of the usb. My motherboard has win uefi or other for secure boot options, i have tried both with both csm settings.
    – circlol
    Sep 26 at 4:56
  • "above 4g decoding" has no effect at all. Anyway, you should be able to install elementary with the default BIOS configuration. Please follow this guide to create the usb and avoid issues. Also reset your bios settings and try installing with the default bios config.
    – Maccer
    Sep 26 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.