0

I use Elementary on my kiddos computer, but MX on my machine. I am getting her machine ready for her to use for online learning and want to edit the host file to block ads.

I installed MX adblock, eventually, and got it working. Thought everything was fine but did not have internet access via browser when I rebooted. Ping worked, so I was connected, just had no browser access.

Looked around and the hosts file was not in /ect so I created a blank one (had to launch Thunar using sudo to get ANY kind of root access), rebooted, everything is fine.

Next I copied my hosts file off my machine, again with sudo thunar replaced the hosts file in /etc, changed the name of the host from my machine's name to hers ( copy/paste so I got it right ), rebooted, and no internet access via browser.

Went back, deleted the hosts file, made a new black one, rebooted and everything is fine.

Why can't I edit the hosts file and still have internet access via browser? Tried it w Chrome, Epiphany, and Firefox.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.