8

Wireless network icon suddenly missing from wingpanel. Cannot find option in dconf-editor to enable network icon.

I tried

killall wingpanel

but there was no change.

How can I get the network icon back in wingpanel?

  • Can you check whether you have indicator-applet installed? – Giulio Sant Jul 7 '15 at 18:42
  • Have you run updates and restarted your computer? Oftentimes that will solve issues like this. :) – Cassidy James Jul 8 '15 at 18:25
  • I do have indicator applet installed, and I've tried updating fully and restarting. Still nothing. – svh160 Jul 11 '15 at 5:44
  • 1
    I'd suggest to create new user, log under him, and check if the indicator is present. If it is present - you'll know it's a matter of your user's config. If it's missing - you'll know it's something global (something with the package probably?). Try it out and let us know the results - we'll then consider directions – V_Pavel Jul 14 '15 at 17:19
  • Tried making another account. Once logged in, the network icon was not there. Something's gone amiss with the package. – svh160 Jul 15 '15 at 19:41
6

The fix was to reinstall libappindicator and reboot.

Here's the link to the answer: https://askubuntu.com/a/586319/203856

4

Since the problem persists even on another new account it doesn't like it's a problem with an auto-start or visibility, it's something global, which I would bet on a package corruption...

I wrote a general troubleshooting post, just in case anyone else stumbles upon it with a slightly different problem. However, please follow all the steps to make sure. if it doesn't help - post us with results from each step.


First of all, lets check if nm-applet is in place in your system and it can be actually launched.

  1. check if nm-applet is in-place:

    # ps aux | grep nm-applet
    

    if it's in place it's only a problem of visibility, check step 4. If it's missing - check step 2.

  2. check binary and package presence:

    # ls -la `which nm-applet`
    # dpkg -V network-manager-gnome
    

    If it's missing or any problems with package - reinstall network-manager-gnome package. If everything is ok - move on to the next step.

  3. If everything is in place - try to start it manually by running following command:

    # nm-applet
    

    If it keeps running and does not exit, and icon appears - it means its an auto startup problem. go to step 5

    If it keeps running without icon appearing - move on to the next step.

    If it exits right away - troubleshoot the exit errors. You can even try to strace as binary doesn't have many debug options:

    # strace -vtfs1024 -o /tmp/nm-applet-startup.strace.log nm-applet
    
  4. If you've reached this place - it means your nm-applet can start just fine but you don't see the icon. probably issue is the visibility. Check it by calling gsettings:

    # gsettings get org.gnome.nm-applet show-applet
    

    if it returns false - bingo. That's the problem. Now call gsettings again to enable its visibility:

    # gsettings set org.gnome.nm-applet show-applet true
    
  5. If you've reached this place it probably means your nm-applet works fine but does not start automatically. we can fix that

    Open settings, locate Applications and Startup. Add "nm-applet" over there. I know in luna it can be different a bit but you've got to figure it out, I don't have Luna :) Should look somehow like on a screenshot below

    nm-applet autostart manual configuration

  • The nm-applet process is present. Once in step 4, however, I try # gsettings get org.gnome.nm-applet show-applet and get: No such schema 'org.gnome.nm-applet' – svh160 Jul 17 '15 at 20:55
  • @svh160 it could be because of the difference in Luna/Freya. Try "gsettings list-recursively | grep nm-applet | grep show", hope it helps – V_Pavel Jul 17 '15 at 20:57
  • Output of gsettings list-recursively | grep nm-applet is blank. Output of simply starting nm-applet is : ** Message: applet now removed from the notification area ** Message: using fallback from indicator to GtkStatusIcon – svh160 Jul 17 '15 at 20:59
  • try launching it with # nm-applet --shell-debug – V_Pavel Jul 17 '15 at 21:01
  • Output of # nm-applet --shell-debug: ** Message: applet now removed from the notification area ** (nm-applet:32634): WARNING **: Failed to register as an agent: (32) No session found for uid 0 ** Message: using fallback from indicator to GtkStatusIcon ** Message: Starting applet secret agent because GNOME Shell disappeared – svh160 Jul 17 '15 at 21:02
1

Had exactly same issue on Elementary OS Freya. This worked for me:

sudo apt-get install indicator-applet
sudo apt-get install indicator-application

Originally found on google+ forum

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.