0

I'm running Hera 5.1.7 on a Lenovo Thinkpad. This morning when I turned on my computer the Wifi Settings were gone completely. I've tried restarting the computer and the wifi settings are still missing.

When I run sudo lshw -C network, the output is

*-network UNCLAIMED
  description: Network controller
  product: Wireless 8265 / 8275
  vendor: Intel Corporation
  physical id: 0
  bus info: pci@0000:02:00.0
  version: 78
  width: 64 bits
  clock: 33MHz
  capabilities: pm msi pciexpress bus_master cap_list
  configuration: latency=0
  resources: memory:ee2200000-ee201fff
*-network
  description: Ethernet interface
  product: Ethernet Connection (4) I219-V
  vendor: Intel Corporation
  physical id: 1f.6
  bus info: pci@0000:00:1f.6
  logical name: enp0s31f6
  version: 21
  serial: 98:fa:9b:33:22:e8
  capacity: 1Gbit/s
  width: 32 bits
  clock: 33MHz
  capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 1000bt-fd autonegotiation
  configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k firmware=0.1-4 latency=0 link=no multicast=yes port=twisted pair
  resources: irq:146 memory:ee300000-ee31ffff
4
  • I ran this and received the following message, linux-headers-4.15.0-156-generic is already the newest version (4.15.0-156.163). The wireless settings are still unavailable.
    – Clayton
    Sep 9, 2021 at 23:15
  • First remove bcmwl-kernel-source if you have already installed. Then run sudo apt-get install linux-headers-$(uname -r). After this install the bcmwl-kernel-source again Sep 13, 2021 at 13:23
  • Thanks for the help @shrestha_aj I followed those steps and after trying to install bcmwl-kernel-source I got the following error - modprobe: ERROR: could not insert 'wl': Required key not available
    – Clayton
    Sep 21, 2021 at 0:45

1 Answer 1

0

Connect a lan cable and install your wifi drivers:

sudo apt install linux-headers-generic-hwe-18.04 firmware-b43-installer

By the way, you can update to elementary 6 if you want. The solution for elementary 6 is:

sudo apt install linux-headers-generic-hwe-20.04 firmware-b43-installer
2
  • Thanks @maccer, do you know why/how the wifi drivers were dropped? I've been running Hera without issues for years now.
    – Clayton
    Sep 8, 2021 at 20:31
  • After running sudo apt install linux-headers-generic-hwe-18.04 firmware-b43-installer and rebooting my system, the wireless settings are still not visible. Here is the output from sudo lshw -C network is the same as before.
    – Clayton
    Sep 9, 2021 at 23:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.