I have recently installed the new Elementary OS 0.6 on my laptop and PC. Before I had Kubuntu 18.04 installed on the laptop, and Elementary 0.4 on the PC.

In both computers, the USB ports didn't power off on suspension, however, after the Odin install the USB ports tend to power off, forcing me to unplug and plug the USB peripherals in order to get these working again.

This wasn't a problem on a previous version and a similar OS, but it does happen on the current version on both computers.

Is it a change in the Ubuntu 20.04 base, or something connected to elementary OS Odin?

1 Answer 1


On terminal:

cat /proc/acpi/wakeup

This will show you every device that may be "awake" during sleep. "On" means awake and "off" is just off. If you want to know what every device is, you can use the command lspci and compare the digits.

To switch the state of a device with the name "XHC" you need to execute the following:

sudo su
echo XHC > /proc/acpi/wakeup

This will solve your issue. Beware that some tools like TLP or powertop may also modify this settings.

  • Assuming I want to use TLP (on my laptop), what should I do in order to prevent it from closing these ports?
    – Kerek
    Sep 8, 2021 at 19:07
  • And thanks! I will try it out on my PC and accept it.
    – Kerek
    Sep 8, 2021 at 19:07
  • 1
    TLP has a specific option to enable/disable USB at shutdown. You don't need to do all of this if you just edit the tlp config file.
    – Maccer
    Sep 8, 2021 at 19:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.