0

After a recent update to the kernel headers (I believe), the system cannot boot correctly off the newest initrd iamge (5.11.0-34). It can still boot if I go into the advanced options in GRUB and select (5.11.0-27). The boot up screen just spins, and if I hit escape I see an error message to the effect of being unable to find the "data" volume/volume group.

I have already tried recreating the initrd image and updating the grub configuration with update-initramfs and update-grub.

4
  • That is unlikely to be an elementary-specific problem. I think you'll have better luck asking on AskUbuntu.
    – m93a
    Sep 10 at 18:18
  • Same problem, makes no sense to have an elementary site with questions to be redirected to a different product site if we are not using it. Sep 11 at 13:26
  • here the xorg logs from trying startx pastebin.com/aZKM1VXB Sep 11 at 13:55
  • I have the drivers installed and have no problem with the old kernel, only the newer kernel this happens. Sep 11 at 13:55
1

I eventually ended up figuring out how to fix it from a live iso (had to as the older initrd image I was previously using also stopped working). I imagine anything would work but for the sake of completeness I used a Fedora 34 live ISO.

  1. Boot into Live ISO
  2. Open a terminal and run sudo su (for convenience)
  3. Figure out which device has your luks partition if encryption is in play (mine was /dev/nvme0n1p3)
  4. Run cryptsetup luksOpen /dev/nvme0n1p3 cryptdata
  5. Run vgchange -ay
  6. Run the following mount commands
mount /dev/mapper/data-root /mnt
mount /dev/nvme0n1p2 /mnt/boot (substitute nvme0n1p2 for whatever your boot partition is)
mount -t proc proc /mnt/proc
mount -t sysfs sysfs /mnt/sys
mount -o bind /dev /mnt/dev
  1. Run chroot /mnt
  2. Run apt install lvm2 cryptsetup-initramfs
  3. Run update-initramfs -c -k all

A few additional notes:

  1. If you did not enable encryption in the installer you may not need to do any of the steps involving cryptsetup. You may not need to do the vgchange either as I'm not sure whether LVM is used when you don't enable encryption during installation.
  2. Make sure your live environment has internet, and if you get name resolution errors in the chroot environment then you may need to edit /etc/resolv.conf to add a known-good DNS nameserver (such as Google's public DNS 8.8.8.8)
  3. If you get a warning during the update-initramfs about cryptdata not being found, then you'll need to check your /etc/crypttab to see what the name is in there (should be at the beginning of the first line). Then you'll need to unmount everything, run vgchange -an to deactivate the logical volumes, run cryptesetup luksClose cryptdata to close the luks encrypted partition, and then repeat the steps, substituting the name from /etc/crypttab in place of cryptdata.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.